Varifing code with the CLI

I’m curious what everyone is doing in terms of code varification.

The Arduino ide has a pretty good utility that tells you what line of code the compiler choked on

When I just tried to comple with the Spark CLI I got something like this.


throw er; // Unhandled stream error in pipe.
Error: EISDIR, read

Keep in mind I just edited a project to port over to the core. I expect the code not to compile because I missed a semicolon or made a typo or something of the like. Just need to get an idea where the problem is.

Are we supposed to be using something else to varify code? Maybe I’ll try the web IDE again.

Could you update the Spark-cli?

That’s an error with Spark-cli and not your code.

Or rather maybe your code caused the break but Spark-Cli should handle it better.

Adding @dave here :slight_smile:

I just updated and got the same error

How is it supposed to behave?

Which command did you run?

As it happening for all commands?

Ran spark cloud compile “myprojectdir”

Also ran and spark cloud nyan out of curiousity and desire for pop tart cat and now my core is barfing rainbows

Here is a link to the code I’m working with github

I just started working on moving the code over, Its a bit unrulely at the moment. Nothing requires a fancy library though, its just a matter of me getting into a good sparkcore workflow to debug the device just prototyped.

I’ll try to compile and get back in a while

Normally the webIDE and local builds give you something like this:

/displaytest.cpp: In function 'void loop()':
/displaytest.cpp:23:5: error: expected ';' before 'Serial1'
make: *** [/displaytest.o] Error 1

So that is a missing semicolon in sketch "displaytest.cpp" on Line 23 in column 5 (which is the line after the missing semicolon).
1 Like


i would appreciate a screenshot from you :smile:

No Spark-cli related weird errors for me but a code error:

I will ping @Dave just to see what he can suggest :smiley:

Only difference I can see are a couple extrafiles in the folder trying to be included

attempting to compile firmware 
pushing file: ../braille/.git
pushing file: ../braille/bluefruit.h
pushing file: ../braille/braille.ino
pushing file: ../braille/buttons.h
pushing file: ../braille/capcitive.h
pushing file: ../braille/debug.h
pushing file: ../braille/npm-debug.log
pushing file: ../braille/pagers.h
pushing file: ../braille/
pushing file: ../braille/timer.h
 throw er; // Unhandled stream error in pipe
    Error: EISDIR, read

Your output leads to the quustion of how I replace progmem, but I guess we can takle one issue at a time. Maybe I’ll try differenet code and try to update again. I will note that I am using Ubuntu 13.10 and I had to do something abnormal when installing the spark cli a few week ago. Something about adding and untrusted ppa and a couple dependencies. To me anything besides apt-get install is abnormal, I distro hop a bit… programs that require a multi step install process tend to not get reinstalled unless I really want it. I had a multi boot usb burner that worked amazingly… but I stopped using it because it took a couple hours to reinstall the thing… I mean thats ironc because the point of the muliti-boot is to distro hop… anyhow I degress, really another tangent


i think the .git file might be the cause

1 Like

Is there a way to exclude it without removing it?

I use git for just about all my code, this problem would persist

What is npm-debug.log?

Add in a spark.ignore file and add .git in the 1st line.

npm-debug.log is used by the npm module of Node.js. It has some debug stuff but we don’t need it here.

Try and let me know! i’ll file an issue if this fixes it :smiley:


That solved the problem, Thanks!

I’m sure there is a thread around here on the progmem thing I’ll take a look and start debuging.


submitted an issue if anyone wants to keep track