Strange listening mode behavior


I am trying to push credentials to a Photon via iOS and am encountering some strange behavior.

Clear all wifi credentials on the Photon.
Restart and it goes into listening mode.
Connect with Particle app.
Enter credentials, but mistype password = push invalid credentials to Photon.
The Photon restarts, tries to connect to wifi for 2 sec (blinking green) then goes back into listening mode.
But this listening mode is inaccessible, the SoftAP is up again but there is no way of connecting to that SoftAP. I have tried to restart the Particle App and connect to the SoftAP (Photon-XXXX) but it fails.

The only way to re-establish a connection is to restart the Photon, then it end up in only green blink mode and then press Setup button to enter listening mode. It is like on the first restart it enters a bricked listening mode.

This is a real life scenario when a customer enters the wrong wifi credentials.


Thanks for reporting this. I’ve managed to reproduce the issue and have filed a tracker here

We’ll endeavour to fix this in the next release.

I just tried again, and it’s working for me. (I’m testing on a laptop connected to the Photon’s SoftAP - can still contact the TCP server on port 5609.)

I’d made a mistake of not reconnecting to the SoftAP on the second try.

Perhaps the mobile is also suffering the same problem and not reconnecting WiFI to the Photon’s SoftAP?

I am testing using the latest release on github - 0.4.4.rc.3.

Please update your system firmware to that and see if it makes a difference - this issue may have already been fixed.

Thanks :smile:

@TheAmos @henkep I’m wondering whether you have tried the latest system modules in v0.4.4 (now past release candidate stage) Does this solve your issues? If not, definitely let us know.

[Edit] TheAmos, I’m referencing your post here: Photon SoftAP refuses connection or requires password

1 Like

@zachary We are using a system we compiled locally from the develop branch. Our pull was from about 8/18 I have also confirmed we can make this happen to a fresh device that has taken an OTA update to the latest production released system.

Thanks much — I’ll make sure this stays on the firmware team’s radar. :+1: has been reopened for tracking and prioritization.