Sparkulator - Multiple file problem

@jgoggins,

I was trying to get the SD Library up and running to test my microSD shield but this happened.

Not sure what i clicked but the files all became lib1.h and after deleting one, the latter happened

That’s really strange.

Relying on the Internet to be up and working or the servers at Spark Devices to “always” be on, well, its no fun when things go wrong; and that’s just wrong.

Next week I will dedicated time to make it all the way with through Local Compiling and flashing my spark… I was able to do the firmware patch flash of my Core using dfu-util but, have not been able to get MAKE to work on my Windows Computer. Not sure if it is realted to /%PATH STATEMENT%/ yet; or not.

You just gave me a good idea to use the trusty-old-cmd Spark Cli to compile all these! Awesome :smiley:

1 Like

Hi @kennethlimcp

This is a bug that the Sparkulator has had before and I know that the team thought they had killed off. If you have not already tried it, I would logout of the Sparkulator, exit the browser to be safe, and restart the browser and try again.

I will add @jgoggins and @Dave here so they see this is a problem again.

@bko,

Is there a max number of child files that can be compiled with the Sparkulator ?

I don’t know if there is a maximum number of files in the Sparkulator. I have a project with 10 library files plus the main .ino file and that works OK.

@bko,

Thanks for reply and that good info.

I think the plan was to deploy updates to the IDE tomorrow, so I’ll let those guys know.

Thanks!
David

1 Like

Hey @kennethlimcp , thanks for reporting this, also gonna ping @shime as well who also works on the Sparkulator and see if he’s got any theories, suggestions, or questions that could help understand this issue better.

I’d love to triangulate a way to replicate this so this allegedly squashed bug can be officially, permanently, and no doubt-about-it squashed for good. If anyone has a reliable way to replicate this problem, please chime in.

The CLI is definitely one way to get around this. Another approach is to create a new app and copy and paste the code into tabs in the new app–I know that has worked for people in the past.

A few questions

  • Was this app created a long time ago or newly created?

  • Could you share the app ID with me? (i.e. https://www.spark.io/build/<THIS_BIG_LONG_ID_HERE>) I’d like to look closer at the underlying data structure in the db.

  • What happens on a hard refresh? (hold shift key + click refresh button in chrome) Still there?

Theories

  • If the app has existed for a long time (like since February), I suspect there could be something about the old data structures in the db interacting with the currently deployed code causing the issue.

  • An asynchronous javascript race condition issue in which most of the time everything works fine, but occasionally due to unlikely timing of clicks the error shows up.

No, not currently. At some point, I can imagine putting something in place though (it would be a very high number like 50 maybe).

3 Likes

@jgoggins,

  1. I think the App is like 1-2 weeks old. I took an app with just a few lines of code and renamed it before using

  2. 534602ecf0f733381a000cc6 not sure if there is a log history but i don’t think so cos i already cleared those file. I should have left it for your debug!

  3. Never tried a hard refresh but what happens is when i delete the .h or .cpp file, all gets removed. The other .h and .cpp files have already appeared to be lost/removed after this happen.

Let me know if you need more info :smiley:

Thanks for the details @kennethlimcp . I looked into the underlying data + logs for this and unfortunately nothing surfaced. I don’t know why this would be happening for you, I can’t come up with any evidence to support my theories above.

If it happens again, please post here and if possible–if someone is able to reliably replicate the issue, please describe the steps to do so, so this bug can be squashed for good.