Spark App crashes


My spark app crashes after naming the core, the LED light turns flashing cyan seems
to indicate that it has connected to the cloud, but after that I can’t connect to the core,
could someone give me a clue? Thanks!

Hi @hpkmw - can you tell us more about the issue? What kind of phone are you using (iPhone/Android)? When exactly does it crash, and does it display any error messages or allow you to send a crash report?

I have similar issue. The LED light is flashing cyan but I cannot connect to my core either. The difference is that my app does not crash. I tried with Android (4.2.2) and iOS. I also tried to connect to different hotspot. Still not working.

My phone is Samsung Galaxy S3, the Android version is 4.1.2
I can set the wifi credentials, after that the app asks me to name the core.
After entering the name, I wait for several seconds then the screen blacks out,
a black message box tells me the spark has stopped and there is a button to
report. The LED keeps changing color and finally it becomes flashing cyan.
I have to reset the core to factory default in order to connect to it again.

@hpkmw have you reported the crash? If so that will give us the stack trace that we need to fix the bug.

@hpkmw @julianshen When you say “flashing cyan”, does it every switch to “breathing cyan” (i.e. slow pulsing light instead of flashing)? Can you please private message me your email addresses for your Spark accounts? We’ll take a look at our logs and see if we can figure out what’s going on.

Sorry, how should I send a private message? I can not find any where to create one.

Yes, it does switch to “breathing cyan”.

@julianshen; To send PM, just click the profile img of zach, then you’ll get a popup that will allow you to.

Sorry, it was breathing cyan. I will report when i go home this evening

Hi ScruffR,

Thanks, but I can’t still see the PM function in popup. I checked my profile. Not sure if it’s related my trust level or something.

I can’t see the PM function either

I have reported, please take a look, thanks

Hey @hpkmw, thanks for reporting! We’re working on publishing a fix later today that will hopefully fix that bug.

@Steph and @julianshen I have just checked on my Win 8.1 tablet with different browsers.
Chrome 31 does show PM,
IE 11 and Mozilla Firefox 25 do not.

Hey everyone - sorry about the mix-up with private messages, not sure what the issue is there.

In any case, we just pushed a new version of the Android app that should fix the crashing problems. @hpkwm please try again once the new v0.1.2 version has propogated through Google Play (should be the next few hours).

@julianshen I am guessing what happened is that claiming your Core is not working. Claiming a Core is the process that connects a Core to your account; it’s supposed to happen automatically but it may not be, in your case.

Try again with the new app, but if that doesn’t work, there’s a manual way to claim your Core. You should:

  1. Connect your Core to your computer over USB (see here:
  2. Press i to read your Core ID
  3. Go to the web IDE (
  4. Press the “Cores” button on the navigation bar on the left to open the Cores drawer
  5. Press “Add a new Core” and follow the instructions. NOTE: Your Core has to be online (breathing cyan) to be claimed.

Hopefully this works, if not please let us know! Sorry for the janky process, we’re working on improving this process to make it more reliable, as well as improving documentation for when it doesn’t work.

Hi Zach,

Thanks. It works with manually claim the Core online.

1 Like

The updated app works, you guys are great!

1 Like

I’m having similar problems here.
I managed to connect the core to the Cloud and it’s sleeping nicely with a blue colour. When I start the tinker app I can assign pins, bit when I than tap the pin again the app crashes.
I can read on this forum there is a newer version out of the app. Can you confirm you updated the app in all the stores as the version in the UK itunes stores still shows version 1.0

I’m using an IPhone5s with version 7.0.4

The cores is working just fine as I can program it via the WEB app. LED at pin D7 is now flashing

@wolterink this issue has been resolved through a back-end server update. If your Core is not working with Tinker, or may have to “Re-flash Tinker” to that Core, which can be done in the Cores menu on the left

Hello Zach,

This is what I have done so far.

I reset the spark core a few times (10sec reset) and added again via the app. The setup all goes fine but I can’t assign pins via the app (crashes).

I also done a reset and followed by the manual way, done via the USB method. Added the core manually to tinker but his also resulted in the app crashing.

Is this what you suggested?

I’m seeing the same problem as wolterink. All was working fine yesterday, but today the iPhone app is crashing. It ignores reflashes and although it acknowledges flashes from the IDE, even a blinking LED app won’t actually download and flash. I can’t add the core again in the app or claim it in the IDE.

…but I get the breathing cyan LED status…