[Solved] Which firmware is installed?


I followed harrisonhjones guide http://support.spark.io/hc/en-us/articles/203108844-Perform-a-Full-Firmware-Upgrade which worked fine.

my core responds however still with SSID on usb. According to https://community.spark.io/t/tutorial-upgrading-factory-reset-firmware/3430 this indicates V01

Does harrisonhjones guide upgrade all of the following ? (is there is any difference between them, i am unclear on what is updated when)

  • factory reset firmware,
  • firmware,
  • build firmware,
  • deep update patches

How do i check current installed versions of all of the above? and why does the core still respond with SSID on usbconnect?


@gijs, as @kennethlimcp pointed out, the method for determining the firmware version on the core is only reliable for v01 or v02. If you followed @harrisonhjones steps, you have the latest factory reset firmware and CC3000 patch on your core. However, remember that every time you flash your app to a Core, it contains the latest firmware as well since it is all compiled with your app. :smile:

OK Thanks!

I would like to point out that, as flattered that I am that someone thought I wrote that helpful support article, that’s not actually my work. Not sure who wrote it, someone on the Support team (other than me) most likely :smile:

I’m going to mark this as solved. If you have any other or additional questions (or plan just feel like this matter isn’t solved) feel free to respond and I’ll remove the “Solved” asap.


1 Like