[SOLVED] Using Asset tracker shield with Photon

Mod Edit (@harrisonhjones): Solution: Adding an external GPS antenna to the Photon configuration solve the problem.

For firmware development debugging, I would like to use the Asset tracker shield with a Photon.

When I use a Photon, the GPS acquires a fix (red light goes out) but the majority of NEMA sentences the Photon receives are $GPGSA with very few $GPGGA sentences. My application sample the position and time every 15 seconds for 8 sample and then use publish and a web hook to sent the package of 8 samples to my website - with the Photon there are insufficient fix to collect 8 samples in any reasonable time.

When I replace the Photon with an Electron, the majority of the NEMA sentences are $GPGGA sentences and all works as one would expect - website receives packages of 8 sample every two minutes.

In both cases, the the hardware is in the asset tracker box with the cover off and the USB cable connected. There is no WifI antenna on the Photon. The firmware used on both Photo and Electron is the same - one flashed over WiFi the other OTA.

Any suggestions on what I might be doing incorrectly with the Photon.

When I set Time.zone(0), and used Time.now() to read the Unix seconds, I always get the Local time when I expected UTC time. According to the Doc, Time.now() should not that the value of Time.zone(0.

Is there some trick that I am missing?

BTW: The application is tracking racing sail boats in real time - well every 15 seconds.

Thank you for you assistance

Thanks for posting. It would be good for us to be able to see the exact firmware you are flashing to your device. Can you post that?

Have you tried the newer AssetTrackerRK library also available on Build?

Unless you have removed the chip antenna which is soldered onto the Photon, that’s probably not the case :wink:

You could try an external GPS antenna to boost the GPS recpetion in case the WiFi signal is interfering with the GPS signal tho’
Another point to consider is the current balance of your setup. How are you powering the whole lot?

Do you by any chance use Time.setTime() instead of getting synced via the cloud?
Usually the Time.zone() setting does not change the output of Time.now(). You can try that by having a test program that just syncs once and then sets different zones and subsequently printing out Time.now() and Time.local(). The former should not reflect the zone change, but the latter should.

BTW:

That’s synonymous WiFi is OTA (over the air) too :wink:

Thank you. Adding an external GPS antenna to the Photon configuration solve the problem.
Photon does not have an external WiFi antenna.
The Electron configuration does not require a GPS antenna to work successfully.
I am powering both configuration via USB.

I think the Time.now() issue is my problem with code on my host site.

I am currently use the libraries that load through with the IDE.

Much appreciated

2 Likes

Glad you got the issue resolved. Can we mark the OP “SOLVED” or do you have any other issues we should take a look at?

Be free to mark it as resolved.