Adafruit GPS Photon problem


#1

Hi all

I just bought the Adafruit Ultimate GPS breakout board (Ultimate GPS Breakout).
I’m trying to connect this to my Particle Photon and read the data from it.

However, something very weird is happening.
First I wired it like this: (like in this post)

I used the same code (ported Adafruit library) and unfortunately I only received this data:

After hours of trying to fix this, we decided to try and put an Arduino in our setup. The arduino provided the 5v and sent the data to our Photon Serial 1.
Sometimes we received some data, sometimes we get the same output as above.

We are absolutely clueless and have no idea how to fix this.
We even put the GPS sensor outside, walked on the street, tried it inside,…

Any thoughts?


GPS interference from Electron
#2

Hi @samhendrickx,

Good question! I think the GPS board is extremely sensitive to both RF interference and power supply quality. Can you try moving it to its own breadboard, and powering it with something like the 3v3 line from the photon, or something like 3 AA batteries in series?

I’m dealing with this same issue trying to convert my photon/gps example to the electron and finding my power supply is probably not clean enough.

I hope that helps!

Thanks,
David


#3

Hi Dave!

I just moved the GPS breakout to another breadboard and powered it with the 3V3 from the Photon.
I’m still having the same issues.


#4

Random side question – Did you use my photo of how I wired my Spark Core / GPS breakout? That really looks like my old photo… Which is awesome!

You’re using a photon yes? not a core? (pictured is a core :slight_smile: )


#5

Yes I’m using the Photon (but I powered RX1 -> TX2 & RX2 -> TX1)
We just placed the gps outside and started receiving some data. But it’s rather unstable and when we reboot it sometimes stops providing data.


#6

Hmm, why don’t I bust out my GPS module and a photon and try this here and see if I can’t make it work. I’ll try to post later today with my results.

I think I had better luck on the core because it had the extra clean 3v3* power line that was filtered, and I think this is not present on the photon.


#7

Ok.
Thanks in advance and keep me posted :wink:


#8

My colleague is also recommending maybe throwing a ceramic cap across the vin/gnd on the GPS module to help eat noise and current dips.


#9

Ok I will try this asap and let you know!


#10

We moved everything to a bigger breadboard and put a ceramic cap in it. (on the breadboard is the rest of our “project”)

Still not receiving any data.


#11

Making sure the clock battery was in properly, disconnecting my external GPS antenna, throwing a cap on the power lines, and waiting a good long time finally let me acquire a GPS lock.

in the end I used the same code / library, but I also experimented a bunch with a photon that was in manual system mode. Interestingly, putting the photon into DFU mode, allowed the GPS module to be powered, but not interacted with, which helped it get an initial lock, after that (with the clock battery), subsequent locks were much faster.

I hope that helps!

Thanks,
David


#12

Looks interesting! Did you get the lock inside or outside under clear sky?


#13

I was able to get a lock inside, 10 feet from the window, but the skies had cleared up. I’m still trying to understand what prevented the initial lock, but I can confirm it can work.


#14

Ok thank you very much for the information. I’ll let you know when I got it working.


#15

I plugged in the cap (like you did) and went out to an open field and got a fix pretty fast. Inside it is impossible for me to get a fix but once I want outside and waited a bit, eventually I got one.

This Youtube video describes some tricks to get a fix:

Troubleshooting the Adafruit Ultimate GPS When Not Getting a Fix

Thanks for the help!


#16

I’ve been having some similar issues with this GPS module. Thanks for the idea of adding the cap (although the photo seems to show an electrolytic cap, while the text says ceramic; I suppose both might be good too, like a 10uf electrolytic and a .1uf ceramic), but what did you actually end up using?

A couple of other thoughts:

Why is this thing so finicky? Everything I’ve read about it online seems to suggest that it’s a modern, high-quality GPS module. But if so, what’s my LG phone got that this module doesn’t? My phone (and a few others I’ve tried, including iPhone 5s and Galaxy 5) can get a GPS fix, from a cold start, inside the house, within a few minutes worst-case. Even if the phone is using the cellular network to get its initial bearings, using a GPS diagnostic app shows that it actually starts finding and using GPS satellites within a minute or two. So what’s the difference?

I know that using the module’s RTC will help speed up the fix time. OK. But without the battery, and from a cold start, I’ve seen that the module gets a time “fix” fairly easily (even inside), before it reports any satellites or location data; how is that possible? Where is it getting the time from?

Assuming I don’t want to power the RTC, is there a way to simply set the time (i.e. the Electron I’m using already knows the time)? I read through the module’s data sheet and app notes, but I can’t find any command that seems like it would allow me to set the module’s clock. Any ideas?

I have two other GPS modules on order (from Sparkfun) that I’m going to play with, too. If nothing else, to have a point of reference.


#17

Thanks for your reply.
I have actually the same thoughts about the difficulty with getting a proper fix.

I ended up using a cap like the one in the picture (not a ceramic one) and get fairly good results outside under clear sky. However it is still impossible for me to get a good fix inside.

Hope someone can provide us with some insights about this.


#18

I have the Adafruit Ultimate GPS receiver and I can get a Fix inside my garage with a aluminum garage door in about 5 mins max and its usually just a couple mins from a cold start. I do have the backup coin cell battery added which helps find your location much quicker every time.

The Adafruit Ultimate GPS module is a good one and the initial GPS lock does take some time sometimes but if you have the coin cell battery added it will be much quicker on all future starts if you have not moved to much from the location it was last located when you powered it down.


#19

I’ve been playing around with this GPS lately, and I have had issues with it. My understanding is it is reasonably powerful, but I do hook up an external antenna for inside use.


#20

its almost always rf interference. caps can help but try disabling any other wifi cellular devices and see if the fix is better. i had competotors use a gps module with cellular trans and they couldnt get data through reliably. turned out they used tcp when we used udp, we woud send a fix gps would cut out during tx then come right back competotor using tcp had too much tcp overhead back and forth and couldnt get fix back before next tx window and would never get past one ffix