[Solved] Spark Core offline with local Cloud

I’m experiencing some problems making my Core works with a local cloud installed on a Raspberry Pi.

Everything seems working fine:

  • local cloud server is setup and working
  • core keys are loaded onto server
  • server keys are loaded onto the core

but the core doesn’t seems to be able to complete handshake with the server. The observed behaviour is:

  • core is breathing cyan
  • then starts blinking fast cyan
  • then breathing cyan again
  • at some point it start blinking cyan super fast and remains in this state

I tried various fix, and readed this topics ( and other irrelevant topics ):

but nothing worked.

The firmware uploaded onto the core is the master branch of the core-firmware repository ( that should be the Tinker app ). ( has been upload via usb and dfu-util )
Device is listed as offline by particle list.
I’m correctly logged in to the local cloud:

Current profile: local
Using API:
Access token: xxxx

What am I doing wrong? Here you can find the server log for the session.

Thank you.

What is your nodejs version?

1 Like

v0.12.2, both on my laptop and on the local cloud server

Hmm, could you try with say, 10.36?

The logs are indicating some kind of crypto error is happening, it makes me think the device has the wrong server public key.


WOW! :slight_smile: It was that easy! Node 0.10.36 worked beautifully. I’ll submit an issue to the spark-server repo to notify about the issue ( the raspberry pi install guide makes you install latest nodejs ).

Thank you.

PS: Should I add [Solved] to topic title?

Hi @endorama,

Awesome, glad that fixed it! Sounds like we have some updating to do to make sure things work with the latest Node. Totally free free to mark solved if you’re happy with the thread :slight_smile: