[SOLVED]Readings from miceuz's soil sensor


I recently ordered and setup an I2C soil sensor bought from miceuz on Tindie. I’ve connected the sensor to 3v3, D0/1 (with 10k pullups) and GND as per the pinout defined for the sensor. I successfully get a connection to the sensor and receive it’s address (hex 20) and a soil moisture of 256 in dry air. I get a 512 reading from the moisture sensor when in water or held in my hand. Pretty sure this is wrong. I also don’t get a temp reading, a sensor version reading, nor a light reading. Any ideas what I’ve done wrong? I’m using the library and instructions found on the Github site referenced by the seller. Everything compiles and runs without error on the photon.


For comparison, when hooked up to an Arduino Uno using the same library (Apollo77), the Arduino correctly reads the ~300 for a reading in air , graduated readings up to 700 for wetness, and gives me the version, temp, and light readings. Same wire setup, etc. Just switching the 4 i2c wires from board to board. Must be a software thing I’m guessing.

Solved. It was an address conflict problem with the ControlEverything NCD2 relay board my Photon was plugged into. Change the jumpers to modify the I2C address of the board and all is well.

1 Like