[Solved] "Program blocked" error Particle CLI for Webhooks in Windows

I am having trouble with installing Particle CLI for using Webhooks. I am NOT trying to connect my core to computer or trying to do a local build. My goal is just to use webhooks with my core.

I am using a 64 bit windows 10 computer. This is a shared computer. I login as a user, but I have admin rights to install software. Installed Node.js 0.10.40. Opened cmd prompt. Checked the npm version and got the below result.

Your environment has been set up for using Node.js 0.10.40 (ia32) and npm.

C:\Users\ssssssss>npm -v

Installed Particle CLI and got the below message (are there any errors in my installation?)

C:\Users\ssssssss>npm install -g particle-cli

serialport@2.0.5 install C:\Users\ssssssss\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport
node-pre-gyp install --fallback-to-build

[serialport] Success: “C:\Users\ssssssss\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport\build\Release\node-v11-win32-ia32\serialport.node” is installed via remote
C:\Users\ssssssss\AppData\Roaming\npm\particle -> C:\Users\ssssssss\AppData\Roaming\npm\node_modules\particle-cli\bin\particle.js
particle-cli@1.8.16 C:\Users\ssssssss\AppData\Roaming\npm\node_modules\particle-cli
├── fast-luhn@1.0.2
├── xtend@4.0.1
├── cli-spinner@0.2.1
├── chalk@1.1.1 (escape-string-regexp@1.0.3, supports-color@2.0.0, ansi-styles@2.1.0, strip-ansi@3.0.0, has-ansi@2.0.0)
├── cli-table@0.3.1 (colors@1.0.3)
├── node-wifiscanner2@1.1.0 (os-locale@1.4.0)
├── when@3.7.5
├── glob@4.5.3 (inherits@2.0.1, once@1.3.3, inflight@1.0.4, minimatch@2.0.10)
├── request@2.67.0 (is-typedarray@1.0.0, aws-sign2@0.6.0, forever-agent@0.6.1, caseless@0.11.0, stringstream@0.0.5, oauth-sign@0.8.0, tunnel-agent@0.4.1, isstream@0.1.2, json-stringify-safe@5.0.1, extend@3.0.0, node-uuid@1.4.7, combined-stream@1.0.5, qs@5.2.0, mime-types@2.1.8, tough-cookie@2.2.1, form-data@1.0.0-rc3, bl@1.0.0, http-signature@1.1.0, har-validator@2.0.3, hawk@3.1.2)
├── hogan.js@2.0.0
├── moment@2.10.6
├── lodash@3.10.1
├── softap-setup@1.1.4 (nconf@0.7.2, node-rsa@0.2.26)
├── inquirer@0.8.5 (ansi-regex@1.1.1, figures@1.4.0, cli-width@1.1.0, through@2.3.8, readline2@0.1.1, rx@2.5.3)
└── serialport@2.0.5 (bindings@1.2.1, async@0.9.0, sf@0.1.7, nan@2.0.9, debug@2.2.0, optimist@0.6.1)

Tried to login to particle and got the below errors

C:\Users\ssssssss>particle login
This program is blocked by group policy. For more information, contact your system administrator.

C:\Users\ssssssss>particle setup
This program is blocked by group policy. For more information, contact your system administrator.

I tried all of these steps by using the cmd prompt in admin mode. Still get the same program blocked error. How do I resolve this error?

My goal is just to use webhooks with my core. Are there any other methods to use webhooks without using the particle CLI?

Any help would be appreciated. Thanks

I figured out the problem. For some reason my computer was blocking access to the program “Particle.cmd” in folder “C:\Users\ssssss\AppData\Roaming\npm”

Solution: Move the “Particle.cmd” to C drive (or documents). Then edit the “Particle cmd” and change the path of “particle.js” to “C:\Users\sssssss\AppData\Roaming\npm\node_modules\particle-cli\bin\particle.js”.

Now open cmd prompt. Point to the location where you moved the file to and execute the particle commands.