[Solved] P1 Freezes when calling a wifi function

Here’s a fun problem:

I’m having trouble with a P1 that seems to be having issues with WiFi. Unfortunately I don’t remember how it was behaving before I patched the system firmware (to 0.4.4).

The P1 runs great in MANUAL mode, but as soon as I call a WiFi function (connect, ready, connecting) it stops responding. LED breathes white as it should in manual mode, and stops breathing (brightness gets stuck, color stays white) when I call a connect function.
Some additional bits of info:

  • Trying to put the device in Listening mode causes the same behaviour as above.
  • I verified the memory using ST-Link against the system files.

[Edit] Problem was solved after re-baking the PCB. Not sure what could have been the issue, but it must have been a short/bad solder joint.

Have you tried updating to 0.4.6? I finally have a P1 (two actually!) which I can run tests against so I’d be happy to help if I can.

Not yet,
I’m using 0.4.4 as my known stable dev snapshot. I have other P1s running fine, just one that looks defective as I described above.
mdma moves too fast with releases for me to keep my code up-to-date.