[SOLVED]Flashing with local ide via cloud not working

Hi There

I can flash my photon using the web-ide, but same code can not be flashed with spark dev using cloud compile.

  1. firmware is created in directory (when compiling, but not uploading), but without PLATFORM prefix which is mentioned in the docs, so it looks like: firmware_1438532585115.bin

  2. photon blinks in magenta when flashing. Seems to take much longer then using web-ide. After flashing, previously flashed code (from web-ide) is running.

  3. IDE tells me: “Update started …” but nothing is coming after…

Any ide why flashing via web-ide is working but not with local ide using cloud flashing?

BTW: Using blinkin light for testing, so no external libraries included…

Thanks for any help.

Hi @metforx

It sounds like your are compiling your code for a Core and not a Photon. What exact command are using to compile?

1 Like

Make sure you’ve selected a photon as the target device when you click compile.

Thanks for the help. Where exactly can i choose my device type in the IDE (not on console)?

If i select a device it properly shows up with the related name in the bottom left corner of Spark Dev, but where do i have to choose the board type?

well i do use cloud compile from ide directly… thought for a start i would use this until i move further to console, if needed.

Selecting the device you want to flash to should suffice. The board type should be detected automatically.
Make sure you’ve only got the files in the directory that are necessary for compiling, without sub-folders.


Hi Moors7

I installed it on my desktop osx (mavericks) and here it’s working as it should. It might be that some background process is hanging on my laptop. Had to manually kill the process after quitting Spark Dev. Will give it a try later today.

So far the problem seems solved with mavericks, will check on yosemite later.

Thanks anyways.

@Moors7, it was the hanging Process, it works now. thx

6 posts were merged into an existing topic: Particle Build working and Particle Dev failing to flash