[SOLVED]Factory reset not working, board not working whatsoever

My Photon started behaving very weird last night and none of the post that I have looked at show the behavior mine is experimenting.

After trying to flash it last night with some code, the LED blinked magenta as if it was being updated and then it went off, completely dead. I hit reset and then it would go to green and then eventually light up cyan although not in a “breathing” fashion as described in the documentation.

I tried uploading some code after that and it won’t work. Tried different USB cables and still same issue. At times when plugged in, the board will boot green and blink then go to cyan and then turn off again.

When I tried a factory reset it will go through the normal magenta blinking and then yellow but it will stay in yellow.

Any ideas of what I can do here?


There is no factory reset on the Photon and it’s documented.

Try Safe Mode.

1 Like

Thanks! I went into safe mode now is breathing magenta! Looking at the documentation, I don’t think that state is described. I also tried reseting the wifi, I configured it again but still, it will like cyan and no code could be uploaded.

Breathing magenta IS safe mode. It’s most certainly documented, with the color state in bold: https://docs.particle.io/guide/getting-started/modes/photon/#safe-mode

In safe mode, try flashing a really simple app like ‘blink an LED’, or Tinker. That should trigger any firmware upgrade, if needed. Those apps are also known to be working so that excludes any user errors.

1 Like

It works sorry about all the misunderstanding, at first I was reading the core documentation all the time. and then reading the states for troubleshooting I feel so stupid.

Thanks for the help!