[SOLVED]Electron Sim Activation

Having issues activating Electron & Sim Card, tried the mobile app (crashes the app after I scan the ICCID and hit the Activate button) using both “Activate SIM with Electron” or with just “Activate SIM”, tried the setup site setup.particle.io in both Chrome and FF both say “temporary activation problem,” IE just doesn’t say anything at all and fails to get past the page.

What’s going on? This process shouldn’t be this buggy, I have used these (Spark Core, Photon and now Electron) for a while but a problem right up front is going to make new users exceedingly frustrated right off the bat, especially with something so simple… :frowning:

Working now it seems? I entered one of the promo codes I got and it came up, not sure if it was the 30 minutes I waited, or the promo code, but I activated another one via the mobile app without the promo code and it came up just fine. Weird but solved.

I have exactly the same issue, and it’s happened to me twice over the past few months. I’ve tried activating SIM cards on both the app and through setup.particle.io.

At this stage the error I repeatedly get whilst using setip.particle.io is:

The same error occurs if I just try to activate the SIM, and if I try to activate the SIM and device at the same time.
I’m using Safari, and have successfully activated multiple sims & devices in the past through the same means. I’m doing absolutely nothing different now, which is what makes this error so strange and frustrating as a user.

I don’t get any error message with the app (using most updated version on iOS 10.2.1). Instead, the app simply crashed after hitting “Activate SIM”

More info:
I cleared my history and tried again on Safari -> same error.
I tried the same thing on Chrome -> same error.

If you look here, there is a note about this

1 Like