[Solved] 0.4.7 Broken Multithreading?

Hi all

This may be a localized issue as I haven’t seen any other posts about it, however since updating to the ‘develop’ branch (0.4.7) multithreading on my P1 doesn’t seem to work during startup anymore.
To clarify, when I was running 0.4.6, my application code ran before the WiFi had connected which was awesome. However now, multithreading only seems to start working once the cloud connection has been established… e.g. if I unplug the router after the connection has been made, my application loop continues to work while the Particle tries to connect (as expected), however only if a connection has already been made.
I have tried exactly the same code on both 0.4.6 and 0.4.7 and there is a clear difference in functionality.

Any ideas would be great!

Not quite sure what changed between 0.4.6 and 0.4.7 but I’ve managed to fix this by moving around the order of some of my setup code, perhaps a cloud related function was blocking the setup function until it connected. All sorted now :smile:

1 Like