System Threading stopped working [SOLVED]

I started OTA-ing some P1s last Wednesday (03/16/2016) and noticed the System Threading stopped working properly using the same 0.4.9 release build.

I have been using System Threading since 0.4.6 when it first came out and it had been working perfectly until last week. For my application I really need to be able to start running loop() regardless of mode or connectivity status.

Anyone experiencing the same? I was wondering if something is changed in the web IDE compiler last Wednesday.

@Dave, @mdma, @ScruffR?

1 Like

Since no one else chimed in it doesn’t look like an issue other people are having.

Are you still seeing the issue if you reflash the previous application firmware that was working, using the 0.4.9 system firmware?

Hi @jvanier,

Indeed. For some reason I totally misused

if(!WiFi.hasCredentials()) WiFi.listen();

in the setup() so it was hanging up until connected.

I reverted the P1s to the old code and did a compare and saw this line. Not sure what I wrote it for but problem solved!


1 Like