Solid Magenta after a reboot

After updating my MODEM’s firmware, and having my Spark Core offline for about 6 weeks, I thought I’d connect it back online. However, it is refusing to boot past the solid Magenta LED. I have tried setting it (WiFi) manually via Putty (Serial), and over WiFi with my phone, and I get to the same point. I have plugged the Core into a wall wart, as I read on here that the PC won’t supply over 100ma, although I have never had a problem in the past with this thing. I’m about at wits end, and I think I’ll just chuck this piece of crap in the bin, and play with my two new Photon’s that arrived yesterday instead. [disappointed]

Anyone else waste half a day trying to get their old Spark Cores working? Fast fix tips would be appreciated, and I have no interest in blowing away Windows 10 to use Linux for a fix.

@KegRaider, by definition, a USB 2.0 connector will supply a max of 500ma to a device so the PC is fine. Have you done a factory reset on your Core?

Hi Peekay123,

Thanks for the reply. Yes I did a factory reset (white flashing LED), readded the wifi credentials via my phone and also did the same via Putty with the ‘i’, ‘w’ keys once connected via the serial connection. I also renewed my API key as it said it had expired, no dice, I am still getting solid magenta.


I think you may need to flash the latest factory firmware using particle cli - solid magenta means the core is trying to receive an update from the cloud.

Please see the instructions here. [Old Spark core] Unable to setup device

Exactly the same issue on mine… I can’t understand why the last factory firmware cannot load by itself?
otherwise the last firmware worked perfectly… I don’t care to have an old version.

Since 2 days, I try to update this factory firmware but the DFU-util doesn’t work :frowning:
I have made a post in french, just in case someone could help…

@KegRaider, did you solve this issue?

I can get the DFU utility to list the core, but it won’t detect the core when it’s time to flash. I dead set have given up on it, my time is worth a lot more than this kickstart core is, so i’m cutting my loss. If my my two new photons go the same route in a few months because of some back end changes, there is no way I will support the particle crew again. I can’t see the value in things that have a limited shelf life.

Thanks mdma,

However, the flash tool won’t send the data to the core. It suddenly cannot detect it upon flashing. Listing the core, finds it and lists out two lines though. I spent the better part of 8 hours searching the forums and performing most of the steps listed, short of installing linux…

Hi @KegRaider,

My apologies to you that this is taking much of your time. I just noticed you mentioned Windows 10 in the original post. My understanding is that the USB management has changed considerably on Windows 10, so this may be why things aren’t working as they used to.

The first step is to see if Windows is even recognizing the device. After putting the Core in DFU mode, visit Device Manager and verify if the Core appears as a device.

Alas, I don’t know Windows 10 in detail to be able to suggest anything further - hoping someone from the community who has this installed can offer some advice on setting up DFU with Windows 10.

Well, I'll be a monkeys uncle!!! I found my old core sitting behind my bench, where the bin was! I class that as a sign my friends! Anyway, I thought I'd give the old girl another shot at revival. Hmm, 5 minutes and its alive again. I must have grown a more level head about the approach, although I am using a newer laptop this time, still with windows 10, so who knows.

Threads followed to get her alive again.

Basic rundown goes:
Put spark in DFU mode.
Install the DFU driver with "Zadig" application.
Install the Node.js 32bit tools
Install the OpenSSL 32bit tools
Install Python 2.7.6
Run "npm install -g particle-cli"
Created a folder in C: called "C:\firmware-spark_2"
Added my path to the environment "set PATH "%PATH%,C:\firmware-spark_2"
Made sure I could see the Spark Core with "Particle list"
Extracted all files and firmwares into my path that i set. Including the contents of the "Build" folder for the core firmware from github
Backed up my device, just in case "dfu-util -d 1d50:607f -a 1 -s 0x00020000:0x00022000 -U backup_frfirmware.bin"
Flashed the newer firmware to the Core "dfu-util -d 1d50:607f -a 1 -s 0x00020000:leave -D core-firmware.bin"
After the final command, to do the old factory reset (MODE + RESET).

Sorry to drag this old thread up, but just in case someone is searching the interwebs for a solution still, my quest is over in a positive way. :slight_smile: Many happy's again!