Help Setting up a Spark v1.0

I recently pulled out a v1.0 Spark Core that has been gathering dust, and I tried to set it up, but I can’t get past using particle cli to update the firmware. Whenever I run the ParticleCLISetup.exe (Windows 7, 64-bit), I get the error “Your internet connection seems to be not permitted or dropped out! Please reconnect and click Retry to resume installation.” Retrying the installation results in the same error again. I tried using putty to manually set up the Core, but after adding the ssid, security type, and password, the LED on the core started rapidly flashing green and wouldn’t stop. All the documentation I’ve found uses either a newer Core, or the particle cli. Any recommendations?

You probably need to reset all of the software on the Core. However, you’ll run into a problem as it requires the use of DFU mode (blinking yellow), and DFU mode is not supported on Windows 7 64-bit.

DFU mode works on Windows 7 32-bit, and both 32-bit and 64-bit versions of Windows 8, 8.1, and 10. It also works on Linux (both 32-bit and 64-bit) and Mac, but unfortunately not on your operating system. Do you have a different computer (or even a virtual machine, Raspberry Pi, or Windows XP 32-bit) you can use instead?

1 Like

I have a Windows 10 64-bit I can use. Once I put the Core in DFU mode, how do I do the software reset?

Thanks! I really appreciate your help.

Put the Core in DFU mode by holding down both the RST and MODE buttons, releasing RST and continuing to hold down MODE until it blinks yellow and issue the commands below, in order.

After completing some of the steps the color may change to something else; if so note what color/pattern it is, then use the button combination to get back to blinking yellow. The core should be blinking yellow before each of the commands listed below is entered.

particle flash --usb --factory tinker
particle flash --usb deep_update_2014_06
particle flash --usb tinker
particle flash --usb cc3000
particle flash --usb tinker

Additional instructions are here:

Then put the Core in listening mode (blinking blue) if not already in that state by pressing and releasing RST. Then holding down MODE until it blinks dark blue. Then issue the command:

particle serial wifi

The normal sequence is white, blinking green, blinking cyan (light blue), fast blinking cyan, and finally breathing cyan.

I followed your instructions, and the Core is now breathing cyan. I logged in to, but the Core (which I got used from an acquaintance) is already claimed. There is an option to request transfer of ownership, but I don’t think they are using their particle account anymore. Is there any way to re-claim it?

The request to transfer is sent to the email address for their Particle account, so if they’re still using that email they’ll get the message and can just click on a link in email to approve the transfer.

Cores are particularly problematic to transfer, so if they don’t respond in a few days create a support ticket and we can use a different process to unclaim the device for you.

I think I may have claimed the Core ~4 years ago using an email I have since deleted. To check, I tried to make a new particle account using my old email address and got the message: ERROR
Username @ already exists. That being the case, should I just go ahead with a support ticket?

Yes, create a support ticket. Include the device ID of the Core (using one of these methods) and include the email address that you think it might be, as well.

I just created a support ticket. Thanks so much for your help!