Shield Shield Digital Out Voltage (with respect to I2C)

I was wondering if the Digital Pins output 5v on the Shield Shield. From the look and sound of it there is a level shifter built into for Arduino compatiblity. I was trying to connect a cheap 20x4 LCD with I2C backpack and ran into some issues. I ran some I2C address scanning code and it just got back errors (return of 4) I.E. nothing. In desperation I even tried using a 10K resistor to pull up the sda, and scl pins on the shield to 5v and still nothing.
I took the core out of the Shield and put in on a bread board using 10K to pull up the communication lines and it found the address (0x27) and turned the backlight on and off. Sort of success. I haven’t had a chance to get any further testing.
1)Does the Shield Shield Output 5v signals
2)From the documentation on the Shield Shield, D0 == Digital Pin 3 and D1 == Digital Pin 5, is this correct?
3)Is there an optimum pull up resistor for I2C on the shield shield? (I know that the size of the resistor affects the clocking frequency.)

Never used the Shield Shield ,but check this out:

and if you get it working properly and continuously, please let us know here:

That is the main post I used to get where I am. I used his libraries. I didn’t see anything in there about the shield shield outputs though.

I think the level shifter on the shield shield doesn’t handle the i2C communication well due to the speed required.

Thanks @kennethlimcp! That’s good to know. So to confirm explicitly all the digital levels are shifted up to 5V by the shield? The caveat being the actual shifter delay makes “high” speed communication problematic if not impossible.

@BulldogLowell. I have it running. Spent a little too long trying some different things to get output when it was the contrast. Thought I had it about right. I did not. I was printing “Hello” with a clear repeatedly. It did get corrupted but that was after playing with the contrast, so I can’t be certain I didn’t bump a wire or resistor while moving things around. I have the uptime code running from the above link. I will let it go all night and see what it comes up with. It’s currently at 20 minutes and running fine. I did pick it up at the 20 minute mark to check the chip. The main chip is PCF8574T and basically looks exactly like yours. I’ll report back to the corrupted lcd thread with my findings.

You can’t use communications i2c, onewire etc with shield - tried doesn’t work.