Setup Photon on Local Cloud

Hi Guys,

I’m having trouble when I try to setup my photon on my local cloud. I’m running the particle server/cli on a virtual machine where I dont have wireless adapter. The thing is when I connect my photon to the machine as I did with my core, the particle cli try to configure it automatically but don’t ask to configure manually after it as you can see below.

leo@particle-server:~$ sudo particle setup

Setup is easy! Let’s get started…
It appears as though you are already logged in as
Would you like to log in with a different account? No

PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
PROTIP: Please make sure you are connected to the internet.

I have detected a Photon connected via USB.
Would you like to continue with this one? Yes
The Photon supports secure Wi-Fi setup. We’ll try that first.

PROTIP: Wireless setup of Photons works like a wizard!
PROTIP: We will automagically change the Wi-Fi network to which your computer is connected.
PROTIP: You will lose your connection to the internet periodically.

No nearby Photons detected. Try the particle help command for more information.
Would you like to wait and monitor for Photons entering setup mode? Yes
Monitoring nearby Wi-Fi networks for Photons. This may take up to a minute.
▐ Waiting for a wild Photon to appear… (press ctrl + C to exit)

Any ideas, how should I do it?

Best Regards,

Leonardo Martins

Try using particle serial wifi to setup wifi… Switching over to a local :cloud: requires changing of the public keys if you have not done so :wink:

1 Like

@kennethlimcp Thanks man. I had already changed the keys. It worked smooth!

@leoamrts Are you able to publish events on the local server?

I’ve been experiencing issues doing it.

Hi @marfife!
For me the local cloud is working perfectly.
Can you be more specific about what issues are you having?

@leoamrts I’ve linked the issue in my comment.

@marfife, I experienced some issues like that before, it turned out to be the Node version. I saw in your comment that you tried diferent versions of Node.

I already have tried with RPi and it worked fine. Can you try instaling node like that?

sudo apt-get install git htop rng-tools
sudo dpkg -i node_latest_armhf.deb

If you still having problems after that, I have a little “how to” install, that I made, for RPi.