Setting WiFi credentials error

I have tried to google the forum but couldn’t find my case. I set up my Photon as prescribed and every time it fails on WiFi credentials. I have tried different methods but have the same.

Ps I’m a newbie, but only with what about microcontrollers

Define ‘fails’.

Such as?

What’s the current state of the device?
What devices are you using?
Operating systems?
CLI?
Network setup?

We need some more information to go on other than “it doesn’t work”.

1 Like

Some more background of what you’ve tried and what your network looks like would help

https://docs.particle.io/guide/getting-started/start/photon/#prerequisites-for-setup

I’ve done firmware update (0.5.3) over Terminal (MacOs). I use Particle app on iPhone 6s+. I see Photon Wi-fi, connect to it. But when it comes to WiFi credentials, it says that Setup process couldn’t configure WiFi credentials.

When i try to make same thing over Terminal, it accepts WiFi SSID+password, but says that it can’t connect to the cloud. Device remains in listening mode.

Thank you. I do all the things written but stay stuck on setting up a WiFi on Photon over App.

I for example meant what band, channel, encryption you’re using.

After sending the credentials over serial the device should at least try to connect. After sending credentials do you see it reboot and then flash green for a while before returning to listening mode (flashing blue)? If not, something isn’t right with your WiFi credentials.

As @ScruffR asked, more information on the type of WiFi network you are trying to connect to would be great.

I use Ubiquiti UniFi AP, WPA2 AES. I also tried TKIP and WPA1. APs (2.4 GHz, auto channel selection) are connected to Apple Airport Extreme (2010).

It does try to connect, but says that connection to Cloud failed. Listening mode remains. I did that dozens of times, still nothing after cloud connection failure.

What kind of cloud failure do you get? Can we get a quick video of your unit booting up and showing the failure? Are you behind a corporate (or otherwise) firewall by chance? How is your router connected to the internet?