Setting up particle windows 7 error status offlline


#1

Hi,

I am setting up the particle photon. my task is to upload a simple program that toggles the D7 led on an off but not luck uploading the sketch/code to the photon. Here the situation:

  • The photon is connected to my router and breathing cyan. I can see it from the build.particle.io. but I can not flash any code to it. It says timeout.
  • From the console.particle.io I see the device and the changes of the status from online-offline to auto-update when I plug or unplug the photon from my computer USB.
  • From the Particle Dev. desktop I am able to choose the device but again can’t flash any code to it. Time out error again. -From the command line: Particle list command it shows the photon but it says that it is offline. even though I can see it from build.particle.io.
  • I tried to flash the code directly from the command line, after downloading the firmware.bin:
    particle flash --serial firmware.bin
    I get the error:
    serial: Error writing firmware …Transfer cancelled
    undefined

Thanks for you help to toggle the D& LED light.


#2

Has it ever worked before?
Which firmware version is on the photon? v.6.x.x


#3

I never got to upload the sketch to the board cause of time out error.
The firmware version is: (default 0.6.2)

Thanks


#4

In my eyes you should claim your Photon with the following steps again by using Particle CLI.
Pre: Open your router for acceptance new devices.

Put the Photon into Listening mode (blinking blue) by holding down SETUP until it blinks blue if it is not already blinking blue. Then issue the CLI command:

particle identify

Save the Device ID; you’ll need it later. Also include that in your reply so I can check the claiming status on the cloud side.

Now enter the command:

particle serial wifi
This will allow you to configure your Wi-Fi network.

Reset the Photon. The main status LED should proceed through white, blinking green, blinking cyan (light blue), fast blinking cyan, to breathing cyan. If it does not get all of the way through, include that information in your reply along with copying and pasting the command prompt output. Also, if you get any other colors after fast blinking cyan, including red or orange blinks, contact the Particle-Support.

Only if you get all the way to breathing cyan:

particle device add YOUR_DEVICE_ID


#5

Hi,

Thanks for your replay.

Following your instructions, here is the result:

  • Particle in listening mode (blinking blue).
    particle identify command output:
    Your device id is: 23******bc
    Unable to determine system firmware version
  • particle serial wifi command: after selecting the SSID and typing the password, I get an error message:
    “Something went wrong: Serial time out”

Thanks


#6

I did connect to the photon using putty. It didn’t work for the first try but I someone in another post mentioned that you need to restart you serial connection. I did just that and it worked.

Using putty I used the command:
(i) to get the id
(w) to setup the wifi
then went to particle-cli and added the device using particle device add “device id”

So far so good. I will check if it is possible to upload the sketch.


#7

We are back where we started.

  • From the command line: particle list: shows the device offline
  • From build.particle.io: the photon is there and when I press the Signal button the LED start blinking with different colors. It is online
  • From the console.partilcle.io The photon is there and I can ping it from there which means, it is online.
  • I am not able to flash any sketch to the photon using neither build.particle.io or Particle Dev desktop.
    Error: Request Time Out.
  • Flashing the firmware using the command line, I get this error message:
    Serial:
    Error writing firmware…Transfer canceled

Thanks


#8

Try putting your device in Safe Mode and flash then.

If that works, it’s most likely your code interfering with the update.


#9

Thanks you @ScruffR but it didn’t work. I am still experiencing the same thing.

Is there a way to upgrade the firmware of the photon through the particle-cli?

Is buying a new one a good idea? maybe will work out the box. I need to get this project going.

Thank you guys for your help.


#10

You can use particle update in DFU Mode to update the system firmware and particle flash --usb <yourBinaryFile.bin> to upload your application firmware.


#11

Well, thanks for your help guys. I was not able to make it work. I tried all possible way.

So I ordered a new one and worked perfectly out of the box. I set it up with the phone app and was able to switch the pin7 on and off from the app which I was not able to do with the old one.

I am happy with the result.

I don’t know what to do with the old one though. Any suggestions?

Thanks


#12

Unclaim your old device from the Particle Cloud list and give ScruffR or me a try :sunglasses:
PM message for postal address if you like.


#13

Just to be sure, make sure you upgrade your CLI to the latest version. Then, update the system firmware as well as flashing Tinker.
What’s the current status of the device? What’s the LED doing?


#14

Postler, thanks for your offer. I will if I can’t get it to work.

Thanks for your help


#15

Last idea - did you do what ScruffR suggested?

Download the 0.7.0-rc.3 Binaries and flash one by one in DFU Mode:

particle flash --usb

https://github.com/spark/firmware/releases/download/v0.7.0-rc.3/system-part1-0.7.0-rc.3-photon.bin
https://github.com/spark/firmware/releases/download/v0.7.0-rc.3/system-part2-0.7.0-rc.3-photon.bin

After success you can go to start with flahing Tinker in DFU Mode:

particle flash --usb tinker

Success?