RPi 1 Model B USB root hub becomes permanently disabled after step "Claiming device"

This is rather perplexing;

I have an old Raspberry Pi 1 B (512MB model) that I figured I could give some use again.

I burned a fresh copy of Raspbian Jessie on an SD card, went thru the initial config, ran the Particle Agent install script. At the point of “Claiming the device to your Particle account”, all the lights for the built-in Ethernet jack went out and all of the USB ports went unresponsive. This to me indicates that the USB root hub was disabled.

Now, when I reboot the Pi, it starts up fine - but because Particle Agent is set as a boot service, it kills the USB root hub each time the service loads.

I re-flashed with the Lite version of the OS (no window manager) to see what I could see on the console, and I have confirmed that immediately after the “LSB: Manages Particle Firmware” line shows up, the USB root hub is disabled again.

This is a BREAKING bug. It wrecks the OS on the card unless you know enough to be able to disable boot services when you literally cannot type or connect from another system…

That’s bad. :astonished:

Could you take a picture of of the top of your Pi to check the revision number of the hardware. There are many variants of the Pi 1 out there.

As mentoned by @legoguy, he is using a B+.

As to this issue I have no idea why this is happening.

Sorry for that empty reply earlier; I mistakenly hit my enter key while shuffling things around on my desk to get a decent setup to show you what’s happening (I’m preparing to record a video).

I just confirmed that this occurs regardless of any other configuration changes to the Pi; in my earlier report, I was running an apt-get update/upgrade before installing Particle Agent, and I figured this may be installing some firmware updates for the Pi, so I yet again reflashed the SD card to “fresh”, and tried again - the install-pi script was the very first command to be run on the fresh install.

It caused the same issue.

Attached you can find an image of the Pi.

I have an (even older) Raspberry Pi 1 B 256MB model (first ever B) that I will now try this with, just for giggles…

See this video for a demonstration of the issue. https://www.youtube.com/watch?v=7OgFm3xbQF8

1 Like

I’m sorry, I mistakenly called this a B+, it is an early RPi 1 Model B! I got my models all mixed up. I fixed the title, too.

I have just confirmed that this occurs with both versions of the RPi1 Model B: v1.0 (256MB) and v2.0 (512MB)
https://www.element14.com/community/docs/DOC-78141/l/identifying-your-model-of-raspberry-pi

Now I’m going to test on my RPi 2 Model B…

That confused me as well.

I hope you are successful on your Pi 2.

Well, now I have a different issue, which I will begin another thread about…

Thanks for the details. I’m out for Thanksgiving. I’ll be able to investigate after the holiday.

Let me know if you need anything through your investigation; I have two legacy RPi 1 B’s sitting around that would be happy to run tests.

I’m having the same problem, with the same model. I’ve reflashed the SD card twice and reinstalled the particle package twice with the same result, hanging at the device claiming section. When I restart the pi, it shows the processor is running at 100% and no input is accepted, both over ssh and the usb ports.

I’ve looked into this and the only Raspberry Pi 1 that i have is the Model B revision 1 (256 MB RAM). I can’t get it to boot at all. I’m going to get a Model B revision 2 (512MB RAM) and look at this issue again when I have the right hardware.

1 Like

I am experiencing the same issue (USB keyboard and mouse dies) with a RPi1 B 512mb.

Hopefully a fix is found as I have a couple of them and wanted to give them a new life as particle devices.

Eddie

Yep, same here : I am experiencing the same USB issue on RPi1 B 512mb.

I even reflashed a fresh OS and tried the same process again, with the exact same result.

…hopefully I’ll be able to give a new life to that RPi.

Thanks!
P.

Any updates on this, @jvanier? Anything I can do to help?

Same thing happening to me… I have tried this with a RPi 1 (have it noted on the case that it is a 2011 Model B Rev 1 board)… which I think it is a 256MB unit… I’m in the process of re-burning the Nov '16 Raspbian image so I can get it working again. This was after one install of particle-agent on a ‘used’ Rasbian image, and then then a second one on a clean and updated install. Both times the RPi crashed when claming, and neither USB nor Ethernet work once particle-agent is running.

There is mention on the RPi forum about the Model B rev1 boards having a

design flaw on the PCB which linked the on-chip generated voltages on the SOC and the LAN Chip. It “may” cause contention between the regulators on the two chips resulting in higher than optimal dissipation

Could that have something to do with it???

PS: I just tried my Raspberry Pi 1 B+, and it claimed ok, and is listed on Particle. It also rebooted fine, so it is looking like something very RPi B rev 1 specific so far…

Sorry for the lack of update on this, folks. I have not actually been able to boot the Raspberry Pi 1 I have in my possession so I have not been able to look into this issue so far.

I know this is a a blocker for several people but the only workaround right now is to use a Raspberry Pi 2, 3 or Zero.

Hi,

What is the status on this issue?
I have a Model B Revision 2.0 (512MB) (“Raspberry Pi ©2011.12”) and I’m having the same problem.
I tried twice and as soon as the Raspberry PI is claimed, the CPU reach 100% and the screen is frozen.

Thank you very much!

Same problem here today with fresh Raspbian Pixel and Raspbian Lite.
Raspberry version also “Raspberry Pi ©2011.12” Model B Rev. 2.0 512MB RAM.
No difference using 5V 2A or 5V 10A power supply.