RedbearDUO on VSCode + Particle Workbench

I have 2 RedbearDUO been collecting dust for a while after initial toying around it. I wanted to try out coding from VSCode instead of the WebIDE but I realized that the DeviceOS for RedbearDUO (v0.3.3) is not available when I try to configure the device. I can compile locally without any issue using v1.5.1, or v0.7.0 (which according to RedbearDUO release note, it’s what v0.3.3 uses from upstream).

I get problem when I try to flash via cloud, and the error I’m getting is Flash device failed: BuildTarget not found. Same error for either v1.5.2 or v0.7.0.

If I try configure the version by hand and I get Task not found. Is there any trick I can apply to get this to work? I know RedbearDUO is old, so I don’t expect best support, but at least since it worked on the WebIDE, I don’t see why it won’t work locally.

hi @faulty and welcome to the community!
Maybe @m_m can help here.
Cheers
Gustavo.

@faulty, the Redbear DUO is no longer supported. However, the OS for the DUO is an older custom branch of the Particle DeviceOS. As such, there is only v.0.3.3 available for the DUO on the Web IDE. None of the Particle DeviceOS version are compatible with the DUO so you are stuck with v0.3.3.

2 Likes

@peekay123 thanks. I totally understand that Redbear DUO is no longer supported. I can’t help but wonder if there’s anything I could do to get it working.

Obviously the device to cloud component is still working. I took at look at the firmware for both Proton vs Redbear DUO for v0.7.0-rc6, it’s exactly the same https://github.com/redbear/firmware/compare/release/Duo-v0.3.3…particle-iot:v0.7.0-rc.6 . Locally I can see the rc versions for v0.8.0, but not v0.7.0. Would it work if I manage to add v0.7.0-rc.6 locally as a target? Or it will still be blocked by the cloud side?

Btw, how much longer will v0.3.3 be available on the WebIDE?