Red Flash SOS after calling a remote function

Hi there,

I switched from automatic to manual mode in order to allow system running in case of no wifi connection.

I registered one remote function that reset the MCU and this working on Automatic mode.

Now I switched to manual mode, but after I call the remote function from the Particle Console, the system crash with led red (I cannot count the LED blink because they are too fast).

I checked that the remote function are registered before calling Particle.connect().

Any suggestion?

Without seeing your code, knowing your platform and target device OS version it’s a guessing game, but my first thing to look at would be to check whether your function actually returns an int in all possible code paths.

This would correlate to an SOS+1 hard fault panic (… — … + 1 slower blink)
However, you can always post a video for others to have a look.

BTW, SYSTEM_MODE(MANUAL) would not be my first choice.
The first thing to try would be SYSTEM_THREAD(ENABLED) unless you are likely to take manual control of the connection and transfer integrity, but even then I’d rather opt for SYSTEM_MODE(SEMI_AUTOMATIC)

1 Like

Hi @ScruffR ,

sorry for the missing information.

I use a Particle Photon with DeviceOS 2.0.1.
I forget to add SYSTEM_THREAD(ENABLED), but also after adding this instruction the Red Flash SOS happens again.

I uploaded the SOS video: Photon SOS

Yup, as expected this is an SOS+1 hard fault.
Possible reasons are given here
Status LED and Device Modes - Photon | Tutorials | Particle

To tell more, we’d have to look at your code.

I think I resolved checking the previous code.
I forget to add the return into th remote function callback.

Now the reset works without problem.

Just for my understanding, looking into my video have you understand the error code?

Thanks!

When you watch closely you will see the SOS Morse Code

… - - - … [some slower blinks in this case 1 ] … - - - …

the only interesting part in that is the number of slow blinks between the two SOS codes.

Yup, that’s what I suggested in my first response :wink:

Yup, that’s what I suggested in my first response

you were right,I was convinced that I had put the return value but I was wrong!

Thank you for your time!