Really fast blinking blue (white?) after wifi setup

I think It’s actually the same problem as: Spark core flashing fast cyan after wifi connection, unavailable via spark.io but I couldn’t find a good answer here. @mdma describes my problem perfectly:

It sounds like your white is actually cyan - green and blue mixed. This is the color when the device tries to connect to the cloud. The intermittent red flash indicates a connection error - it seems the core has connected to the router, but cannot connect to the internet.

Any steps you can take to validate the internet connection from the router, such as checking the gateway IP would be my next step.

I already tried a factory reset with the buttons and flashing it via usb with particle flash --usb tinker I also tried downloading the .bin files and manually used the DFU util to flash the Photon.

View the video: https://cl.ly/053n0V0I3V0V

The fast blinking blue in the beginning is the state that it can’t escape from. I’m 100% sure my wifi credentials are correct. This also happens after a flash / factory reset.

I think my photon is broken :frowning: Do you guys think there is anything I can do to fix this?

I think that’s fast blinking cyan. If that happened recently, like within the last hour, it’s because a server outage on the cloud side. The symptom is rapid blinking cyan, separate by a blink of red occasionally. It seems to be working again for me, but I haven’t gotten the all clear yet. You could give it a try again and it may work better now.

Doing a factory reset on a Photon is quite impressive, especially considering… https://docs.particle.io/guide/getting-started/modes/photon/#factory-reset

This topic was talking about the mentioned cloud issues and shown some/most of the same symptoms: Particle API Down?

According to status.particle.io we should be okay again.

@Moors7 You’re right, it’s actually a wifi reset but in my defense it feels like a factory reset… :stuck_out_tongue: however I did flash the device with the particle flash command in the terminal.

It still does not work… The exact steps I went thought:

  • Photon flashed red SOS lights
  • Did a wifi reset (no results)
  • Did a software flash (no results)
  • Did a software update (leds were blinking blue slowly… At this point I thought I fixed it)
  • Tried to setup (setup failed -> leds went blinking blue/white rapidly like in the video)

Also retried doing some of the steps with no results so I thought I’d post it on the forums. I probably broke my Photon but it’s weird because It looks like it still works, thats what confuses me.

some additional info:

This is the screen I get after completing the setup

@Timvdv If the led is blinking light blue (cyan) rapidly it means that it cannot connect to the Particle API. This is likely due to ongoing performance issues with the API. If the device can’t connect to the API, then the iOS application probably thinks there is an issue connecting to the WIFI. As long as the device isn’t blinking green rapidly you are successfully connected. Check out http://status.particle.io for up-to-date information on the API status. Right now connection to the API is very hit or miss. It will likely be resolved in a couple hours. You can also go look here for more info on the API issues.

Though you might feel that way, which is your good right, it really isn’t a factory reset, and doesn’t do anything remotely like it. A factory reset on the Core would flash back Tinker, and erase the credentials, thus getting you back to the actual factory state. A credentials reset on the Photon ‘only’ erases credentials, but leave behind your user code, which is most likely the reason for the issues you’re seeing. As such, resetting credentials won’t make a difference, if not make it harder to fix.

Have you tried Safe Mode, which is kinda made for scenarios like these, and a better alternative to a ‘factory reset’?

Try doing particle update and then particle flash --usb tinker, both while in DFU mode. Then try entering your credentials again if you hadn’t already done so.

furthermore, heed the notion above; there are certain issues with connecting to the cloud, and the symptoms you’re describing, and have filmed, match those rather closely.

If it’s still working, then it’s probably not ‘broken’, though that’s a popular opinion for people to have as soon as something’s not working the way they’d like it to :wink: In this case it’s most likely the Cloud that’s being finicky, but even in most other situations, I’ve found it extremely hard to actually break a Particle device (excluding that one time I put 12V on it :confused:)

My photon has exactly the same behaviour, started about 5.00am CST, started working again after half an hour but went wrong again at about 9.00am CST and still has not recovered.

One thing to note in addition. Your video does show the rapid cyan flashing, but not really long enough to tell, if there is a quick orange burst somewhere in between.
While a lack of that would rather speak for the recent cloud outage or some blocked cloud communication (e.g. CoAP port 5683 closed on your or your ISP’s firewall), its presence might suggest some issue with the keys.

In that case there are some threads, that deal with orange burst like this

particle keys doctor <insertYourDeviceID>
particle keys server

But the status page http://status.particle.io/ still reports issues with the cloud, so it might well be that

Thanks for all the response. It actually works now!

It were the servers after all… Such a bad timing for me because I just flashed the device.