RadioHead library error (stm32f4xx.h not found)


#1

Hello. I’d like to use one of those cheap 433MHz ASK modules, so I created a new project and installed the RadioHead library (using Install Library in the Workbench).

I copied one of the examples lib/RadioHead/examples/ask/ask_receiver/ask_receiver.pde into my main .ino file, but the build gives the following error:

In file included from lib/RadioHead/src/RHGenericDriver.h:9:0,
                 from lib/RadioHead/src/RH_ASK.h:9,
                 from src/test_ask_rx.ino:1:
lib/RadioHead/src/RadioHead.h:574:24: fatal error: stm32f4xx.h: No such file or directory
compilation terminated.

I tried both cloud build and local build. How can I fix it?

This is the relevant part in RadioHead.h :

#elif (RH_PLATFORM == RH_PLATFORM_STM32STD) // STM32 with STM32F4xx_StdPeriph_Driver 
 #include <stm32f4xx.h>
 #include <wirish.h>	
 #include <stdint.h>
 #include <string.h>
 #include <math.h>
 #include <HardwareSPI.h>
 #define RH_HAVE_HARDWARE_SPI
 #define Serial SerialUSB
 #define RH_HAVE_SERIAL

Is the platform definition correct? What library contains that header?


#2

I solved the issue by using a version modified by @RWB here: Photon LoRaWAN node?

But it would be helpful if somebody fixed (and updated?) the one uploaded to Particle libraries.


#3

There is also a port of the RadioHead RF95/96/97/98 LoRa Packet radio driver for Particle here: