:::: PUTTING DEVICE INTO DFU MODE Device not found: p2

Hello, I have tried to follow the Particle 101: How To Use Particle Workbench - YouTube and put also the device in DFU mode based on Tutorial: Installing DFU-Driver on Windows [24 Feb 2015] - Tutorials - Particle. After trying to flash the device using the VS code (>Particle: Flash application & DeviceOS (local) ). It just says:


Device not found: p2

I've also checked the device from the control panned: Windows is detecting it and P2 DFU Mode is also working.

My device is Photon 2 and I am using deviceOS@5.3.2. Windows 11.

Let me know if you have any suggestion please.

Assuming you're using Photon 2 and it's plugged in via USB, try holding down the mode button. While holding the mode button tap the reset button and continue holding mode until the LED flashed yellow. Then try to flash it.

Thanks for your reply!

I think you suggested to manually put the device into DFU mode, which I did. same error 'Device not found: p2'. Interestingly I could successfully flash the device using Web IDE, which is not my desired place for programming. any other suggestion to resolve this issue would highly be appreciated!

What does the bottom bar of you're VSCode look like?

Thanks for your reply.

I found what the issue was for the respective error. I did not set the target device ID. The error disappeared once I assigned the device ID; thanks for your hint.

Interestingly without assigning the device ID, flashing the device, even with 'Device not found: p2 ' could successfully be done as my code was working. seems like assigning the 'Device ID' is optional and that was more warning than error!

Awesome. Have fun. :+1:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.