Publish + IFTTT + google sheets = bad data

This had been working fine for me up until a few days ago. I have a payload being published every hour, and an IFTTT transfer to a new line in a google sheet. Now it looks as though the data is being mucked up between the event and the sheet eg.

I can see this in the particle console event:
{“data”: “5903,1506664956,2413,65533,1470,64904,1080,666”, "ttl…

Which looks correct so it’s not the device-side, however the corresponding entry in the google sheet is: 590,315,066,649,562,000,000,000,000,000,000,000,000

ie. the delimiters moved, and data lost at the end, weird, anyone else seeing this sort of thing?


This looks like the comma gets interpreted as the number grouping seperator - this is more likely a Google Sheets issue than Particle.
You may need to change the sheets settings to prevent that.
But on the Particle side you can try to replae the comma (,) with a semicolon (;) in your outgoing event.

I was able to re-create by pasting the data copied from the console into the sheet, same result. When a new line is added to the sheet it’s default formatting seems to be the problem. When a manually added empty line is explicitly set to ‘plain text’ formatting before pasting it all works as it should, unfortunately whatever the virgin cell formatting is doing (note it’s ‘marked’ as plain text, but behaves differently) loses most of my data so this can’t be applied retrospectively. Pretty odd behaviour, and like I said only started happening a few days ago so something has moved under the covers on the google side it seems.

Ok I can’t see how to stop it formatting the incoming data such, changing the delimiter looks to have worked around it though.


1 Like