Problems with my Photons

Hi guys ! I really love the Photon, but i’m having problems with all of them !

The first one: when I press the setup button to enter in listening mode, the led turn off.

The second one: the Photon flash cyan (connecting to the cloud) and after there is 3 fast red flash, and it return to flashing cyan. The loop continue on & on.

The third one: works well, but it can’t be recognize by my computer (Cool term) for serial monitor.

The fourth one: Flash cyan (connecting to the cloud) and after the led turn off.

I don’t know what is going on but I really need help !

Thanks !

Do any of them have any custom code on them? If you flash tinker to them do the problems stop? I would recommend picking one and working through the issue then progressing to the next and so on. Since the third mostly works a few things to check…are you rescanning Serial Ports in Cool Term before you try to connect? I have multiple Photons and each shows as a different usbmodem1420, 1421, etc. If that is correct maybe post the code running on it so others can see if anything jumps out at them.

Although it sounds stupid; are you sure you’ve not mixed up the RESET and SETUP button? I assume not, but I’ve done so in the past as well…
If not, is there any external circuitry attached, and could you try doing the same without it? Try holding setup, and then plug it in?

Sounds vaguely similar to this, and might indicate a keys issue. Have a look.
https://docs.particle.io/support/troubleshooting/common-issues/photon/#flashing-cyan

Have you got the proper drivers installed, and have you ever had one working over Serial before? Do you use Serial.begin() in your code, or is it in listening mode?

Could there be code running on there that does that? Could you see if safe mode works on that one?

For the third one, I just test the example from the Internet Button and flashed the thinker, but in either case I can’t see it on my computer. And yes I did rescan the serial ports. I may have broke the Tx communication, it happened to me with an other one…

Neither Tinker, nor the Internet Button use the Serial connection. If it’s not set up correctly, you’re not going to be able to see it. It needs to have either Serial.begin(xxxx); or be in Listening mode.

No the first one is not plugged in anything and I double checked and I’m really pressing on the setup button. When I plugged it while pressing the setup button, at first it’s flashing purple and when I release it start flashing green and when I repress on setup it goes on a steady green.

For the second on, thanks I’ll take a look at the link !

For the third one, yes you’re right this wasn’t the right way (even if this was usually working) so I just tried a simple code with serial.begin() and it’s not working more.

void setup() {
Serial.begin(9600);
}

void loop() {
	Serial.println("test");
	delay(50);
}

The fourth one is now working ! I think it was the code.

Alright, could you try the same thing again (putting it in safe mode essentially)? When it’s in there, (or blinking green if it doesn’t get further), could you try holding setup until it starts blinking blue rapidly (around 10 seconds)?
That should erase the credentials, and might make a difference.

For the third, could you try another USB cable/port? You’d be surprised how often that has caused issues in the past…
That said, have you got your drivers installed properly?

Now I can put the first in listening mode, but it has the same problem as the second one. In both cases, I did a manually firmware update (like they are saying on the link), but when I try to make a key reset, I’m getting this error: Please specify a server key in DER format.

Did you download the file, and are you in the same directory that’s in?

Which files ? If you are talking about system-part 1 and 2 yes. But aren’t they supposed to be for firmware install ?

The .DER file, which is mentioned in the steps I’ve linked to. The error you got indicates it’s not present in the directory ftom which you’re executing the command. For convenience, here’s the file.

Oh I didn’t saw that. The key reset worked, but now the Photon is flashing cyan (longer than originally) and after it’s flashing orange. This is the same thing for both of them.