Problems connecting for the first time

Is this IP address still correct? I’m trying to get my Spark core to connect to the Spark cloud for the first time and am getting the CFOD. I’ve tried all the suggestions on the threads. I’m trying a different router today. I’m getting the same behavior as my Airport router but there were a couple of “breathing” blue and red LEDs during different attempts so I’ve opened up port 5683 to - it seemed to connect to an Amazon cloud server - I then got some garbage text - when I hit return the remote server disconnected.

Hi @jlr,

That is still the correct ip and port, and connecting to it raw won’t give you pretty text, since it’s expecting an encrypted handshake and then an aes encrypted coap session :slight_smile:

What suggestions have you tried exactly? Can you post a video of what you’re seeing?


Here’s the email I sent to support yesterday… I will try and get a video tonight.

Spent the last two nights on the forums trying everything/anything. I have a Spark with ufl antenna which is connected. I’ve tried two routers (second one is a Netgear WNR1000 set to 54000 (g supposedly). No password or security. Mac OS X 10.9.4.

Scenario 1:
Connect to USB
Factory reset (white flashing)
Listening mode (flashing blue)
<attempted Android SmartConfig - lights go through blue to green to CFOD>

Scenario 2:
Connect to USB
Factory reset (white flashing)
Listening mode (flashing blue)
$ sudo npm update -g spark-cli
DFU mode (flashing yellow)
$ spark flash --usb deep_update_2014_06

Johns-MacBook-Air:~ johnreilly$ spark flash --usb deep_update_2014_06
checking file /usr/local/lib/node_modules/spark-cli/binaries/deep_update_2014_06.bin
spawning dfu-util -d 1d50:607f -a 0 -i 0 -s 0x08005000:leave -D /usr/local/lib/node_modules/spark-cli/binaries/deep_update_2014_06.bin
dfu-util 0.7
Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to
Filter on vendor = 0x1d50 product = 0x607f
Opening DFU capable USB device… ID 1d50:607f
Run-time device DFU version 011a
Found DFU: [1d50:607f] devnum=0, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/20001Ka,108001Kg"
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
No valid DFU suffix signature
Warning: File has no DFU suffix
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08005000, size = 93636

File downloaded successfully
Transitioning to dfuMANIFEST state
Error during download get_status

Back to flashing blue.
Android SmartConfig
Password: [blank]
Getting green flashing led, then red flashing led, then green, then CFOD, then flashing green, then red, CFOD, etc…
Android: no cores found.

Scenario 3:
Connect to USB
Factory reset (white flashing)
Listening mode (flashing blue)


Security 0=unsecured, 1=WEP, 2=WPA, 3=WPA2: 0
Thanks! Wait about 7 seconds while I save those credentials…

Awesome. Now we’ll connect!

If you see a pulsing cyan light, your Spark Core
has connected to the Cloud and is ready to go!

If your LED flashes red or you encounter any other problems,
visit to debug.

Spark <3 you!

No breathing, just CFOD.

Previously tried the DFU (tinker, cc3300, tinker, etc…)

Pardon the music… I had people talking in the background so I used the music on YouTube to mask it.
This video was taken when I tried to connect to the core using SmartConfig on Android. It appeared to me that the SmartConfig could access the app because it immediately went to straight blue, then green, then flashing cyan… it seems it is making multiple attempts because later in the video it goes back to blinking green, then cyan… it was then red for some time. You can fast forward to see it quicker obviously.