Problem with flashing firmware[Solved]

I have a problem during firmware flash:
$ sudo dfu-util -l
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

Found Runtime: [0489:e042] ver=0112, devnum=4, cfg=1, intf=3, alt=0, name=“UNKNOWN”, serial=“08EDB9D7EDFD"
Found DFU: [1d50:607f] ver=0200, devnum=23, cfg=1, intf=0, alt=1, name=”@SPI Flash : SST25x/0x00000000/51204Kg",
Found DFU: [1d50:607f] ver=0200, devnum=23, cfg=1, intf=0, alt=0, name="@Internal Flash /0x08000000/20
$ sudo dfu-util -d 1d50:607f -a 0 -s 0x08005000:leave -D core-firmware.bin
dfu-util 0.7

Copyright 2005-2008 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2012 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Opening DFU capable USB device…
ID 1d50:607f
Run-time device DFU version 011a
Claiming USB DFU Interface…
Setting Alternate Setting #0
Determining device status: state = dfuERROR, status = 10
dfuERROR, clearing status
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 1024
DfuSe interface name: "Internal Flash "
Downloading to address = 0x08005000, size = 70932
Download [= ] 4% 3072 bytesdfu-util: Error during download get_status

I can’t seem to flash it, and I’ve been trying many times now.
Anyone had the same problem?;/

I have never seen this being listed. Are there any other devices connected to your computer at the time of flashing?

1 Like

Does the core restart (leave blinking yellow) after the flashing?

That is a Broadcom bluetooth transceiver on the same USB hub.

It might be worth trying to flash without that being plugged in.


Unfortunately it stops the flashing process after 3% and it’s still blinking the same way

It seems to be the internal bluetooth in my laptop.:confused:

Nobody can help me? I still can’t get it to work:(

You are on Linux or mac?

Can you try this:

dfu-util -d 1d50:607f -a 1 -s 0x00020000:0x00022000 -U backup_frfirmware.bin

I’m working on ubuntu 13.04 64bit.
It made a backup of SPI firmware without a problem, but it’s not what I’m trying to do.:confused:

Have you tried using a USB hub between the laptop and the core?

In particular, I would try a USB 2.0 hub, not a USB 3.0 hub.

I don’t have any usb hubs:/ I’ve tried every usb port available, with everything disconnected:/ I’ll try to fight my way on my old windows laptop wish me luck;)

So ok on a windows machine it worked smoothly. The core is back and running. Why the hell can’t it work on linux:/ If I can’t get it to work it will be a pain to flash it on that old one:/

It might be a driver issue as we have users who had dfu-util not working exactly as expected but managed to get it running after changing the driver.

That’s for windows but the same idea should work for linus as well.

Which linux are you on and where’s the driver from?

Thank you for the reply:)
Ubuntu 13.04 3.8.0-35-generic #50-Ubuntu SMP Tue Dec 3 01:24:59 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

[92630.136165] usb 3-4: USB disconnect, device number 17
[92654.014905] usb 3-4: new full-speed USB device number 18 using xhci_hcd
[92654.031925] usb 3-4: New USB device found, idVendor=1d50, idProduct=607f
[92654.031934] usb 3-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[92654.031941] usb 3-4: Product: CORE DFU 
[92654.031946] usb 3-4: Manufacturer: Spark Devices    

Seems like it’s a dfu-util problem on some specific linux platforms and having a sure work fix is not going to happen.

There’s a ‘solution’ i came across here and you might want to try it out:

If I had to guess @Abador, it would be to look at your 64-bit vs 32-bit linux configuration for building dfu-util.

Thanks for the info. I still haven’t managed to make it run on linux. At least on windows the flash process works…:slight_smile: Oh well maybe I’ll be able to fix it some day, but till then it will have to do:)

It’s sadly a linux related problem and I wished the process is smoother like the Tutorial I managed to cook up for Windows to get DFU running!

@Abador did you ever get this resolved? I found this old thread while running into the same problem. There’s another thread that has a solution. You need to patch one of the files in the dfu-util source (a quick one line change and a recompile is all it takes)

See this thread for more info:

Sorry for the long time without reply.
I managed to make it work after format/installing ubuntu 14.04 and with help from this thread:

Thank you all for help:)