Problem installing particle-dev on Ubuntu 18.04

Hi all,

I am trying to install particle dev on Atom, in Ubuntu 18.04. After installing particle-dev-complete, I fail to install particle-dev dependency.
The error i get is :

serialport@4.0.1 install /tmp/apm-install-dir-120029-14069-nexp8o.goi9/node_modules/particle-dev/node_modules/serialport
node-pre-gyp install --fallback-to-build
npm WARN deprecated spark@0.5.10: Use particle-api-js instead
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
npm WARN deprecated cryptiles@2.0.5: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated boom@2.10.1: This version is no longer maintained. Please upgrade to the latest version.
npm WARN deprecated hoek@2.16.3: This version is no longer maintained. Please upgrade to the latest version.
fs.js:143
throw err;

Error: EACCES: permission denied, open ‘/tmp/apm-install-dir-120029-14069-nexp8o.goi9/node_modules/particle-dev/node_modules/serialport/package.json’
at Object.fs.openSync (fs.js:577:3)
at Object.fs.readFileSync (fs.js:483:33)
at Run.parseOpts [as parseArgv] (/usr/lib/node_modules/node-pre-gyp/lib/node-pre-gyp.js:136:36)
at Object. (/usr/lib/node_modules/node-pre-gyp/bin/node-pre-gyp:24:6)
at Module._compile (internal/modules/cjs/loader.js:702:30)
at Object.Module._extensions…js (internal/modules/cjs/loader.js:713:10)
at Module.load (internal/modules/cjs/loader.js:612:32)
at tryModuleLoad (internal/modules/cjs/loader.js:551:12)
at Function.Module._load (internal/modules/cjs/loader.js:543:3)
at Function.Module.runMain (internal/modules/cjs/loader.js:744:10)
npm WARN enoent ENOENT: no such file or directory, open ‘/tmp/apm-install-dir-120029-14069-nexp8o.goi9/package.json’
npm WARN apm-install-dir-120029-14069-nexp8o.goi9 No description
npm WARN apm-install-dir-120029-14069-nexp8o.goi9 No repository field.
npm WARN apm-install-dir-120029-14069-nexp8o.goi9 No README data
npm WARN apm-install-dir-120029-14069-nexp8o.goi9 No license field.

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! serialport@4.0.1 install: node-pre-gyp install --fallback-to-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the serialport@4.0.1 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /ho

``

Do you have any idea why is this happening?

Have you tried running that command under sudo? And update npm (node.js?) as indicated.

I have npm version 3.5.2 and of course all i ve done through sudo

I have the same problem in 3 different pc’s running 18.04 - 2 of them newly installed