Powering the Spark Core with a USB battery

I am trying to power my spark core from a portable USB battery source. I am powering it through the VIN pin which is wired to a female USB connector. When I plug the spark into a standard USB charger (such as my iPhone wall charger) it powers up fine. However when I plug it into anything that is battery powered such as:

It does not come on? Do I need to tie the USB connectors data lines together of something to get these to work?

Have you tried these power banks via the Core’s USB connector too?
Unless you need the USB for serial communication - which would make the power bank superfulous - I don’t see the need to go via Vin (although it should work without any attention to the data pins of the connector).

As for the Adafruit solar panel the max current at 6V looks a bit on the low side and make sure that it doesn’t exceed 6V.
When they state 6V/330mA I’d suspect this to be the max output in fullest sun light, in less optimal conditions I’d expect it to perform not so excellent.

Can you measure the output of your power bank (voltage and current)?

Please excuse the next questions, but you won’t believe what can happen :wink:
Have you connected the correct pins of your USB connector to Vin and GND?
Are your batteries fully charged?


Can you measure the voltage across VIN and GRD? It should be between 3.6V and 6V. If you measure a voltage in the acceptable range, next measure the voltage between the 3V3 an GRD pin. It should be exactly 3.3V. If it is not, that could indicate an issue with the voltage regulator.

It’s also possible the battery does not provide enough current. I believe you need somewhere around 500mA, depending on what you are driving from the pins

So the voltages seem to be fine. I actually got it working with one of these boards:

and a small 1.2Ah Lipo cell.

I thought it was interesting to note that the Lipo Rider wont charge my iPhone but works with the core. The other USB batteries charge my iPhone but do not work with the core. Perhaps something to do more with the resistors on the USB lines? I believe it’s a current issue however the adafruit USB booster is supposed to give me 1A?

Hi @camow7

I have used Goal Zero batteries over USB to run my core from time to time and it has always worked great. These are designed for camping (and solar charging) so they are both more robust and more expensive than other USB battery packs, but great for the intended use.

I know that these batteries have the magic voltage dividing 1% resistors on the data lines since they also charge my iOS device at the “low” 1A amperage, not the “high” iPad 2A current.

I don’t think the core cares at all about the data lines and I have used a +5V wall wart power supply many times too. In this mode there is no connection to the data lines.

Okay so I have solved the mystery. The panel mount USB connector on my enclosure has a ground and shield wire. When I soldered it in I took one look, went “This one is black, must be ground” and hooked it in. Now on all wall chargers the shielding is connected to ground so the wall chargers worked fine. However, on the USB battery chargers the shielding is usually unconnected (with exception of the Lipo Rider which grounds it’s shileding).

Easy fix was to Ground the shielding on my PCB side.