Powering the Core (not over USB)

Hi, again :smile:

I need to power my Core(v1.0) via the PINs. According to the PINOUT diagram I can connect 3,6V up to 6V to the VIN PIN. I have an 8,7V DC power source available where the Core should get into place. So I decided to lower the voltage with a step-down-converter (datasheet).
I set it to 5V on the output side and connected VIN and GND. But this doesn’t work, I’m ending up with a slow blinking red RGB LED. A look at the documentation tells me “Flashing yellow/red: Bad credentials for the Spark Cloud. Contact the Spark team (hello@spark.io).” I don´t think this is the problem. Tests with the USB connection work just fine. What do you think is the problem?
I am confused right now, because VIN for me means variable input - but I also used it to run my i2c LCD that needs more than 3,3V. So VIN can also be VOUT?
Basically I thought I have to do something like @peekay123 did in this thread.

Help appreciated!

You should verify with a normal USB power source to see if this happens.

I suspect that your source does not have sufficient current? (measure the voltage from Vin to Ground and observe)

Yup! You can treat it like a normal power(+) pin :slight_smile:

Vin is simply a label to tell users this is the pin to plug the + side of the power supply.

2 Likes

from what i gathered from various forum posts (the info really should be an FAQ or in getting started) you have:

VIN aka RAW aka PIN1 = power input that can regulate 6v to 3.3v

3.3v aka VCC = power output (some people say its an unregulated input too?)

3.3v* = smoothed power output for analogue devices

USB = power input that can regulate 5v to 3.3v

@clyde have a look at this other thread, we’ve linked to a few regulators/converters there.

2 Likes

@sej7278, Thanks for your comments and let us know what voltage numbers you are getting and the max current provided by your supply.

There is ongoing discussion in the community that docs need improvement and its a big job. I am getting a RV this year, maybe after Spark Team moves to San Fransico I’ll move up there and become there intern Technical Writer. I’ll bet I could learn a lot from that kind of Spark Team position.

Bobby Cooper
Buena Park, CA

@spydrop i’m away from my spark/electronics at the moment, but from the quick play i had, i didn’t have much luck powering the spark from anything but usb.

i tried breadboard power supplies and a few buck converters and the spark acted pretty strangely - couldn’t connect to the cloud, serial didn’t work, i had to factory reset and the bmp180 i had connected died, so i’m not convinced that 3.3v out actually outputs 3.3v if you use a 5v input e.g. usb or 5v to vin.

pretty similar experience to @clyde i guess - putting more than 3.3v into vin makes the core go nuts, like its not actually regulated…?

perhaps @zach could confirm a few things - i think he chimed in elsewhere about in/out voltages.

p.s. yeah, i was a bit surprised when spark inc advertised some jobs and technical author wasn’t one of them, they could really do with one as its too major a task to do via github pull requests from a few contributors.

1 Like

@sej7278, Sorry to see you are having these issues with your spark core. I have only about 10 hours of run time on my spark core so I’m no expert in these issues but, I did experience and issue with supply connect to VIN.

One of my power supplies is rated at 1 Amps but, the voltage dropped when I loaded the core up with LED’s and seem unresponsive at times.

I agree with you 100% about Github and the process involved concerning docs but, I promised someone I would do some docs markup this weekend and see how it goes.

Also, I notice in another thread that you had planed to obtain some buck converters ? So, if you do have different power supplies to test with, does the Core act the same using various power supplies when connecting to VIN ?

Just wanted to add here that a bunch of us have had really good luck powering the core from a +5V cell phone wall-wart type supply, connected to the VIN pin.

I have only tried powering my core from 3.3V once but it did work in my limited testing.

It can draw 350mA at 5V so a really tiny supply is not going to cut it.

3 Likes

I’ve had good luck powering it from 3.7v LiPo batteries via VIN as well. I’ve also tried a couple of 5V wall warts (not USB) with no problems either.

4 Likes

Hi *,

as always: thx 4 all your help. You all are absolutely amazing. Keep up the spirit of this community!

But, back to business!
My power source is a laboratory power supply. Hope you know what I mean. I can adjust the voltage output. As I said in my first post my Core should end up in a place where I have an power source with around 8,xV not sure if x,7 or x,8. The Core takes only 6V (should be) so I connect the step-down-converter (output regulated to 5V) between the power supply (regulated to 8V) and the core VIN / GND. I also tried it with more or less voltage output. But no victory at all. More power changes the RGB LED from blinking slow red to blinking fast red.

I will try it today (maybe tomorrow) what @sej7278 said, first Core directly connected to the laboratory power supply and then again with the converter regulated to 3,3V output.

fingers crossed
Next I will see how much current is drawn. As far as I remember when I connect the power supply directly to the Core it should gives me the value of the current that will drawn from the connected device. I can compare it with the converter. Thx @kennethlimcp:

Maybe there is a problem with the step-down-converter. I will give it a try without that component. In the end I only had the chance to use the 8.x V DC power source, I can´t see any other possibilities. Powering the core over batteries is no option. Anyway let´s do this step by step.

Thx guys, I will let you know as soon as possible.

1 Like

Got the time to test it, and here are the results:

  1. Connecting the :spark: Core directly to the adjustable power supply
    3,3V up to 6,0V -> works fine! No problem.

  2. Connecting the adjustable power supply (8,7V) to the step-down-converter (5,3V) to the :spark: Core
    Works.

W8 what? Yes of course it does!
I found the problem. All the time i measured on top of the screws on the step down converter. That gives me the right results on the input side. Yesterday I got it only running using the input “-” side also for the Core GND Pin. This scenario is also mentioned in the datasheet of the converter. For a noob like me this seems ok. I can adjust the voltage with the poti. But this will not work with the core, result - red blinking.

Today I tried it again and finally found the problem.
All the time (grml) I used my Voltmeter on the top of the wire holder things. Sorry did not know the english word for it. That works fine with the 3 right screws (with and without cables) but not on the left screw… gnaaa! The moment I used the voltmeter where the wires should take place - I got a signal.
Then I am able to use the two right ones as input and the to left once as output. It feels like I am totally stupid. So no problem with the :spark: Core only a Layer8 problem in the end.

Current results of the adjustable power supply :smile:
Current drawn something around 100mA to 120mA; without the LCD
Current drawn something around 110mA to 120mA; with the LCD attached

Some pictues :wink:


PS:
Excuse me for my english skills :wink: but this all is absolutely new for me - I have the same problems explain it in my language :sunny:

3 Likes