Powering from Arduino 5V

I was trying to power my Spark from the 5V output to figure out a powering scenario, now it’s unresponsive when I plug it in to USB and it gets pretty hot. Did I blow it up? I thought it would work up to 6V, maybe I don’t know what I’m doing. =P.

You may have done goofed. Without applying power again would you mind taking a picture of your setup or telling us exactly how you wired it?

If you definetly didn’t exceed 6V “smooth” DC and connected these to Vin on the Core - and not any other pin - you should not have blown anything according to the docs

But the issue you do see, needs looking at :wink:

Here’s a bit of background on my project. I have a programmable thermostat that basically consist of a relay and a power supply. The relay is controlled by an ATmega 169PA microcontroller (came with the programmable thermostat), and the power supply supplies power to that. What I’m trying to do is replace the ATmega with the Spark Core. I got the Spark to control the relay, problem 1 solved.

Now on to problem 2, powering the Spark. The power supply provies 6.75V, which I regulated down to 5V with an 7805 TO-220 linear voltage regulator and a couple of 10uF capacitors. The voltage is now a clean 5V. I tried to power my Spark Core from that through the VIN pin and and nothing happens. The LED on the top right of the Spark flickers, then nothing. To troubleshoot I thought I would try the 5V power supply from my Aruino UNO, since I know more about the Arduino than this programmable thermostat. I first sent the 5V through the regulator, which isn’t enought voltage to be regulated and it brings it down to 3.8V, I plugged it in and nothing happened. So I tried the 5V directly, which (to my knowledge) is regulated by the Arduino. Again nothing happened.

So I gave up, plugged the Spark Core back in to the USB power supply and nothing happened. I noticed that the USB end of the Spark was heating up, I never noticed this before. Here are a couple of pictures of what I tried with the Arduino.



I have tried using the 6.75V regulated to 5V from the thermostat to power the Spark previously without success, but it has always worked again from USB after the attempt.

Thanks for the help.

Have you got any means to measure the 3V3 voltage of your Core?
Maybe the on-bord voltage regulator got damaged - or some people had regulators which got “desoldered” after being over powered for some time.
The regulator is located directly underneath the USB socket and uses it as heat sink.

The 3V3 pin is reading 2.3V, The Vout on the voltage regulator reads the same. That doesn’t look right.

No, it doesn’t.

And the input side - is it somewhere between 4.7 and 5V?

If so, I’d guess the regulator is gone. To figure if the Core itself is still OK, you could try to power it with 3.3V on the 3V3 pin, but be careful.
When it still works, you might just have to replace the reg.

The input side is 4.3V…

I got a 3.3V regulator today and just tried it on the 3V3 pin and nothing happened. Guess I need to invest in a new Spark.