Power consumption on a sleeping Argon not hitting spec

Does anybody have an idea why I am not able to achieve a sleeping power consumption under 100 uA? Here is my code, super simple. Note I have tried this on 3 separate Argons with identical results.

SYSTEM_MODE(MANUAL);
SystemSleepConfiguration config;

void setup() {

    config.mode(SystemSleepMode::ULTRA_LOW_POWER).duration(100000);
    delay(1000);
    System.sleep(config);
}

void loop() {
}

And the Argon is just sitting in a breadboard, nothing connected to it. Power is being supplied by an external power supply at 3.6V through the Lithium Ion Battery connection and I have a NanoRanger in the loop to measure the current. It consistently shows 1.83mA. I am running the latest OS 3.1.0

1 Like

Also, I have tried the current measurements using a Rigol DM3058E and got the same readings.

1 Like

Thanks for your post - I’m also experiencing higher (~600uA) than claimed current draw in sleep on my Borons (device OS 3.0.0). I have not received any feedback on my forum post which is unfortunate.

Out of curiosity, what is your current draw if you pull EN low?

I’ll give that a try in the lab this afternoon and post.

Kevin McQuown
Principal Engineer
Windy City Lab

With EN low I measure 26.9 uA.

1 Like

Interesting. So the excess current is definitely being consumed in the nRF52 and/or ESP32 WiFi module since pulling EN low disables the 3V3 bus to both (see sch here).

I hope one of the Particle engineers would shed shine some light on this since 1.68 mA is a LOT of current in sleep, and is drastically outside of the published spec.

I haven’t dug under the hood, but I wonder if there’s some OS/WiFi initialization going on that prevents the system from fully realizing it’s low current sleep during setup() (i.e. would the results be different if the sleep was called after 60s of nominal operation). Not knowing what nRF52 <–> ESP32 interface looks like perhaps there’s some initialization happening that gets in the way of immediate sleeping of the ESP32? Wild speculation on my part.

I’ll try delaying by 60 seconds before going into sleep today and see what I get.

No change after waiting 1 minute and then entering sleep

Any thoughts/suggestions @rickkas7 or other Particle Engineers?

Same goes for my Boron post linked above.

I have submitted a formal support request with ticket 108250.

Thanks, we’re looking into this for you!