Argon deep sleep mode issues

Hi All,

I’m using an argon to call a webhook and go straight back to deep sleep using

  SystemSleepConfiguration config;
  config.mode(SystemSleepMode::HIBERNATE)
      .gpio(WKP, RISING);
    System.sleep(config);

All of the code is in void setup, I do have some cloud functions that aren’t actively being used(I’m unsure if this affects whether it sleeps or not), and I’m using just the reset button to re-activate it as needed.

The documentation states that:

Typical power consumption in hibernate sleep mode, based on the wakeup source:

Device GPIO RTC
T523 Eval 103 uA 95 uA
T402 Eval 103 uA 95 uA
Boron 2G/3G 146 uA n/a
Boron LTE 106 uA n/a
B402 SoM 26 uA n/a
B523 SoM 30 uA n/a
Argon 65 uA n/a
Electron 114 uA 114 uA
Photon 114 uA 114 uA

So the argon should be using around 65uA in deep sleep, but I’ve tried both 3.7 Lipo 400mah and 500mah batteries respectively and they’re not lasting longer than a day in deep sleep mode.

When it runs the webhook the Argon is active for about 5 seconds total before going back to sleep and it’s only being run once a day.

Power consumption just isn’t adding up.

Is there some trick I’m missing with the deep sleep mode? Is there other components on the argon that need to be manually disabled prior to deep sleep?

Thanks

Ben

What device OS version are you using?
Try the lates RC.

Using 1.5.2, I’ve tried both classic sleep API commands as well as the current ones, makes no difference.

Hi Ben, is there any component or sensor plugged in to Argon?
Is it only the Argon that you have or is there something else?