Photon started to smoke, after connecting battery/USB

So I just wanted to know what I did wrong, and whether my photon is completely destroyed.
I had a 3.7V LiPo battery lying around and I tried to connect it to Vin and ground.

The little black chip next to the ground pin, and above the Setup pin started to smoke, so I quickly remove it.
Then I tried to connect the USB cable, and unfortunately it started to smoke again.

This is not a real answer, but the saying goes
"Electronics run on smoke. When the smoke comes out they no longer work."

This is the 3.3V regulator and if you are lucky this went before µC got frazzled.
To test this, you could use a relyable (!) 3.3V source attached to the 3V3 pin. If your device comes to life you might get away with just replacing the regulator and maybe the protection diode if this went too.

About what you’ve done wrong, it’s hard to say, since Vin should run on 3.6V … 5.5V.
Possible reasons are wrong polarity, not really 3.7V but a multi cell pack (e.g. 2x3.7V) or maybe a drained 3.7V LiPo (<3.6V) causing the regulator to “oscillate” till it blew.