Photon (presumably gen1?) usb/wifi connectivity issues

Hey All,
I’ve had some original v1 spark cores and a photon since the early days (just after kickstarter times).
They’ve been sat idle in a drawer for years and years.
I’ve recently found a project where I’d like to if possible reuse the hardware I’ve got.
From what I understand the spark core v1 is deprecated and therefore unusable.

However the Photon should still be workable right?
I’ve managed to flash the firmware using the IDE to the latest 2.3.0 (had difficulty with this but managed to step it up gradually with the web IDE).
Anyways, I’ve had real difficulty with getting the thing working, it’s showing up in my list of devices, it even shows as online briefly when I turn it on, but then it just reports ‘unreachable’ or offline.
The ‘get vitals’ ‘signal’ and ‘ping’ options all fail.
I’ve tried particle cli, but it doesnt discover the device, I’ve tried particle doctor and it also doesnt discover the device, it just tells me the same thing “Connect a Particle device to a USB port and run the command again.”

The ‘Last handshake’ and ‘Last Heard’ properties have an up to date time stamp from shortly after I hit reset on the photon, and the device goes into a solid (but doesnt ‘breathe’) cyan light, I figured it was connected, yet the web IDE still reports unreachable and I cant do anything with it.
I’ve seen some documentation that state device doctor is only compatible with gen2 devices, I dont know what my photon is in terms of it’s gen, anyone have any ideas? Here’s a pic if that helps to identify it:

I’m really at a loss with what to do here, if any one has any ideas I’d greatly appreciate some steps I can try before I throw this thing in the bin :sweat_smile:

That’s a Photon, not a Spark Core, so it’s a Gen 2 device. You can use the web device doctor or Device Restore USB to restore the ifrmware.

Since it briefly connects to the cloud, it’s most likely a user firmware issue. You can also use Safe Mode by holding down SETUP and tapping RESET. When the status LED blinks magenta (red and blue at the same time), release SETUP. If the device goes through blinking green, blinking cyan, and then to breathing cyan, you can reprogram it through the Web IDE.

Hey @rickkas7 thanks for your quick reply!
I’ve pressed setup and reset as you suggested and it’s breathing magenta (after a period of blinking green and cyan) so I understand I’m correctly in safe mode.
Using the web device doctor just states ‘No compatible devices found’.
Using cli ‘particle device doctor’ I get ‘Connect a Particle device to a USB port and run the command again.’
Are there any issues with usb3? (unfortunately all I have on my PC - windows 10)
I then tried flashing tinker through the WebIDE and it was successful!
It’s now responding to signal and showing as online so I think I’m up and running again! Thanks for the quick and easy steps.
It would be good to understand why I can’t seem to communicate over USB though, any thoughts on how I can troubleshoot that?

That was a typo, edited not to now* responding :')

The most common reason is using a USB charging cable instead of a a USB data cable. But assuming that’s not the case, USB 3 and Windows 10 should be fine. There’s a really rare situation where if you previously did have a very old Particle device, you could have incorrect Windows device drivers, which can be fixed using this complicated process.

However, since you at least have OTA working again, you might be able to delay having to deal with that.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.