Photon my button stopped working

I have a Photon project which has been working great for several years. It’s a familamp that sends colors to several Photons running the FastLED library. It’s been working flawlessly up until recently. One of my devices stopped responding to a button in the device. The button uses the clickbutton library to detect a button press - it basically just grounds D0.

Well, one device has stopped responding to the button. I thought the button had gone bad but testing shows it’s working fine. I tried manually jumpering D0 to Gnd but no luck. I tried changing the sketch, re-flashing to use D1 and jumpering that pin to Gnd - still nothing.

I have a script that uses curl to send api commands and that works fine to send the color change and my device responds accordingly. It just doesn’t want to respond to any hardware inputs.

I guess I’m left with some kind of hardware failure and I need to replace the Photon. Just posting this in case someone has any other ideas before I swap it out.

Thanks!

Are you grounding the pin directly on the Photon board?
I would try a new and very simple program that changes the state of the LED (D7) when you press the button. That eliminates coding issues.
Then I would put that Photon in a blank perf board and try again.

2 Likes

I second Pescatore’s advice and also suggest restoring the device if all else fails.

Could you check with meter if you pin (D0 or D1 depend which you are using) are in “HIGH” stage ? (3V3 when button is NOT pressed) as your switch is just connecting the appropriate pin to GND I’m assuming that the pin should be set as INPUT_PULLUP in setup.
Just guessing that can be some issue with internal PULLUP resistor. Also I’ll try to connect an external 4k7 ohm resistor to the pin D0 or D1 and 3V3 and then test again.
Best,
Arek

1 Like