Photon keeps breathing magenta and loads nothing but the Tinker [SOLVED]

Hi everyone,

after a whole day passed playing with my Photon, suddenly after a simple upload of a new code my board get stuck in breathing magenta: there is no way to do anything.
The only thing I can do is to connect via iPhone App, click on the device that can be found as “online - no tinker” and flash the tinker again.
After that, the Photon comes back to life and I can play with the tinker app correctly. But as soon as I try to upload new code (even the simplest code like blink-a-led) the story comes again: try to upload a sketch, blink green and breath magenta, with Photon Stuck.

Is it Bricked? :frowning:

Thanks in advance!

There has been an update that will automatically upgrade your device firmware to the latest version when you flash your device OTA. That can take a few minutes, during which time the LED will show different color patterns. Try waiting for a bit, it might resolve itself. Try not to interrupt it. Shouldn’t take more than 10 minutes though.


If it does take longer than 10 minutes, please try reflashing your app.

1 Like


I flashed my app compiling on the cloud using Particle Dev. After the Photon restarts, it blinks green, and once it gets connected it stays breathing magenta. It has been like that for the last 10 min.

The photon doesn’t show online in the dashboard or in the Android Tinker App.

Any tips before I flash it through DFU?

Could you retry? Also please send me your device ID so we can investigate. Thanks! :smile:

Good morning,

Thanks Moors7 and Mdma :smile:
Probably yesterday I was too tired… Waiting about 10 minutes the led starts to blink again and I uploaded my sketch correctly.

Thanks again!


I haven’t been so lucky.

I have flashed my photon several times and waited for over 20 minutes, but it still doesn’t run the user code. I have flashed very simple code (LED on) with Particle Dev and the Web IDE.

Any thoughts on next steps @mdma?


Please PM your device ID to me and @Dave. Thanks!

Will do. Thanks!

Hi @sazp96,

I’m learning that DEV flashes the binary directly, and doesn’t flash the source code via the build farm. Flashing a raw binary to your device won’t trigger the auto-update behavior right now, so that might explain what you’re seeing.


Thanks @David. That might be it.

This is the workflow I followed:

  1. Photon initially running V0.4.3rc3
  2. Build user code on the cloud using Particle Dev
  3. Flashed to the Photon from Particle Dev (assuming this would automatically trigger the update to V0.4.4
  4. Photon seems to update firmware correctly but once it restarts it has a breathing purple light

@Dave, is my assumption in step 3 incorrect? Should I explicitly flash OTA/DFU V0.4.4?

One caveat though, when I put the Photon in serial mode and I press “v” I get:
system firmware version: 0.4.4


Yes, you should. Here’s an update on that:

Using the CLI with particle update while it’s in DFU mode should also work.

1 Like

Thank you @Moors7! That did the trick.


Yeah, I fell into the same trap. Bought the device a while ago, but only tried to activate it last night. It was after 1am, I was tired, not sure what happened, but I might have interrupted it after waiting for a few minutes.

Anyway, the result was that today only the tinker app would work, nothing else, not even the simplest blink LED app.

Luckily I’ve found this discussion after some searching. Put the device in DFU mode, did a “particle update” with the CLI. Now any app that I’ve tried works fine.

Perhaps it should be made more clear what we need to expect from the first steps of setting up a new device. Put a big warning somewhere, saying something like “if it’s flashing such and such color during the first boot-up, DO NOT reset or unplug it!”


Put the device in DFU mode, did a “particle update” with the CLI.

Awesome, just what I was looking for! Thanks

Hi @Moors7,
I seem to experienced the same behaviour of a photon. Is this update making the led breathe purple?

If it is breathing magenta or cyan that’s a good thing in general.

Breathing magenta as documented here ( means the device is connected to the :cloud: but not running any user firmware.

What issues are you facing/

Like @kennethlimcp mentioned, that’s safe mode. You should be able to OTA an application of your choice. It should automatically upgrade the system firmware, if it hasn’t already done so. During the process it’ll blink magenta for a while.

If you want to decrease the risk of failure while updating, you could update it manually using the CLI. Hook it up in DFU mode and issue particle update. It’s a lot quicker and less prone to error.

Give it a try and let us know if that worked for you :slight_smile:

One photon updated OTA, the other one needed CLI, I stopped the update because I did not know what happened…
They are both fine now :relaxed:

1 Like

Just to recap:

  • When updating system firmware, please do so from Build (Web IDE) or CLI by flashing a new application. This will flash 3 binaries - the application, system-part1 and system-part2. Do not interrupt the process. If the process is interrupted, then re-flash the application to reapply system firmware.

  • Flashing from Particle Dev DOES NOT update system firmware. In that case, you need to update via the CLI.

# put the device in DFU mode
npm install -g particle-cli
sudo particle update

Or alternatively download the binaries from here and flash them OTA by following the instructions given.

Thanks :smile: