Photon hangs in safe mode after (presumed) partial firmware update


I uploaded a new app to my photon via the web IDE and the firmware update seems to have failed. The LED flashed like usually during the update and then froze for 5 minutes or so. The photon then restarted on its own but now goes to safe mode and after a random time (10-50s) the purple breathing hangs and it disconnects from the cloud. I flashed the same app to a second photon and it works just fine on that.

The photon having the problem seems to connect correctly to the cloud before hanging. Firmware should have been upgraded from 0.4.3 to 0.6.3, it still indicates the old firmware is installed.

I tried the following steps on two different computers (Win7 and Win10), without success:

I tried to update via the update manager, this exits with the fatal error message: win returned -1. The drivers seemed to have installed correctly. Neither listening mode, nor safe mode, nor dfu mode change the outcome.

I tried to run particle device doctor but it does not detect the device, despite it being in DFU mode. DFU driver seems to install correctly.

I tried to update by particle update and manual update procedures using dfu-util, but the device is not recognized.

Zadig does not recognize the device either… But when i plug in the photon for the first time, Windows installs the drivers.

Any ideas?



Can you show a screenshot of DevMgr with your device in DFU Mode?

DevMgr indicates device functionning properly…

And what is the output of

particle -v
particle update

while the device is in DFU Mode (blinking yellow)?
Can you try on a USB 2.0 (not 3.0) port and also try other USB cables?

It was always connected to USB 2.0 ports on 2 different computers with different cables, blinking yellow in DFU mode.

The last few times on this computer I got the message that no device in DFU could be detected.
Something seems to have changed though, I now get this message:

It seems that the photon now boots to normal mode (cyan) instead of safe mode. Firmware is still 0.4.3, so not updated.

That is strange - best tagging @rickkas7

Update: finally got it working! The problem is still, I don’t know how. I completely uninstalled an reinstalled the CLI on my Win7 Pro PC, and it would not work. The Photon is not recognised in DFU mode.
Did the same thing on the Win10 PC (Zotac ZBOX-ID18, just used as an ADSB tracking server) and it actually worked.
I managed to connect to the photon in DFU mode.
The update didn’t work by ‘particle update’, but it worked with 'particle device doctor’
The update function should be the same, or am I mistaken?