Photon getting hot and flashing SOS +1, can't flash tinker or update


#1

Friends,

I fear I may have cooked my photon. From what I gather from the docs i seem to have encountered a hard fault ( SOS +1 red light flashing), and the photon gets much hotter than I have ever noticed. So hot that it hurts to press the reset or setup buttons.

If i act fast (before it gets too hot to handle) i can get it to dfu mode, but any attempt to update or flash tinker via usb kicks back errors. For example, this is part of the error i get when trying to flash tinker;

dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
Deducing device DFU version from functional descriptor length
Opening DFU capable USB device...
ID 2b04:d006
Run-time device DFU version 011a
Claiming USB DFU Interface...
Setting Alternate Setting #0 ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
DFU mode device DFU version 011a
Device returned transfer size 4096
DfuSe interface name: "Internal Flash   "
Downloading to address = 0x080a0000, size = 3952
Download	[                         ]   0%            0 bytesdfu-util: Error during download get_status

Error writing firmware...dfu-util: 
Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!

dfu-util: Error during download get_status

I have search the forum and the docs to no avail. Any insight is greatly appreciated.


#2

I don’t have photon. What kind of power did you add on Photon? USB, Batteries, Voltage, etc.

Can you show us wiring board.
http://fritzing.org/home/


#3

Currently I have it only to usb and not wired up to anything, i believe that the usb supplies 5v but could be wrong. I do also have a power shield and the device reacts the same when hooked up to that.

I dont have a full circuit diagram at the ready but i can tell you that i have 7 of the circuit found in the link below as well as some simple circuits for sensors, dsb1820, a few float valves, etc.

Here is the like referenced above

I have tried almost everything i could find on the forum to no avail.

Thanks


#4

I am also unable to get the device into safe mode. As soon as it starts blinking magenta and I release the setup button it is back to the red sos+1 flashing. I can’t let the stay on for longer than a minute otherwise its too hot to handle.

Should I lose all hope and order a new one, with the hopes that i dont fry that one too?


#5

What DFU did you type?


#6

@jjlee32, the onboard 3.3v switching regulator is most likely damaged which is what is getting hot. This can happen with too-long or poor quality USB cables or a poor quality power supply or a combo of both. If you have a multimeter, measure the voltage on the 3V3 pin.

You can replace the regulator or power the Photon from an external 3V3 supply via the 3V3 pin.


#7

That’s sort of where I am hung up. It says a suffix is required so I do not know what to type in.


#8

I have tried with the stock cord and other micro USB cords i have laying around to no avail.

Would the onboard regulator be affected when the power shield is used because even when I put in on the shield it does the same sos+1


#9

Once the regulator is damaged - which is most likely the case with your description above - changing supply or wires won’t fix that anymore. The damage has been done and the regulator needs replacing.


#10

Is this something I can do on my own? it doesn’t look like it, based off the resistors being the type that a precise robot arm would put into place. It seems that the regulator could be buried inside the layers of the photon. Do i even attempt to locate and replace the regulator?

I have ordered a new one already, but is there anything i could have done to prevent this form happening? I have had that photon for over a year and it has taken all of the noobish abuse one of those can take but was pretty reliable until now. Could it have been a code issue is my main concern?

Thank you all for your help thus far


#11

With a steady hand (or three ;-)), good eyesight and a good soldering iron you can replace the regulator - I’ve done it a couple of times.

Usually you won’t be able to damage the regulator by code alone.


#12

Thanks for all of your help thus far. Is it the regulator directly above the setup button?

I dont think ill take that project on but it’d be nice to know if i ever decide to try and repair this one.


#13

So I was without my DMM for a few days, but now i have it back.

The voltage across the 3v3 pin is still 3.3 V and the Vin pin reads ~5V when connected via usb.

Could there be another hardware fault that could be causing this issue? I want to make sure i do not make the same mistake again.

Thanks