Photon defect? Any option to breathe life?


#1

I have bought a used photon in an online auction house: it arrived today and does not start (no control LED). Do you still see a technical option to breathe life or did I buy garbage?

Is Particle showing off his generous side and exchanging it for me (will praise the lord)?


#2

Have you tried taking it out of the breadboard, using a different Cable and/or power supply?
Does it do anything when trying any of the button combinations?
Is there any voltage on the Vin and/or 3.3V pin you can measure?

Though that would be awesome, it’d also be kinda weird. If you buy a second-hand phone off of ebay, and it doesn’t work, the manufacturer won’t replace that either, would it? You should take that up with the auction house or seller.


#3

and if the 3v3 pin doesn’t have an output you could try powering it from the 3V3 pins using a suitable supply…


#4

Thanks for the help: I’ve tried several USB cables, as well as a USB power bank and now with a 3.3 / 5V breadboard adapter: as a result, the photon became very hot and the smell of it is in Smoky Heavens arrived.