Debugging a Photon with no lights

Short version: Photon gives no lights (or recognition in Windows) after soldering into a PCB, but appears to have basic power (~5V across VIN/GND, ~3.3V across 3V3/GND). Is there any further debugging I can do, or do I just need to cut all connections to completely ensure there’s no shorts? I’m not very good with a soldering iron yet, so it’s entirely possible I got one of the pins pretty hot or something – could that have damaged it?

Long version: I got a Photon with headers earlier today, got my design working on the breadboard just fine - WiFi active, online editing of code, etc. - ie. everything worked great, and while I don’t have all the code worked out, all the I/O is working great. So, I thought I’d move it over a a circuit board so I can start working on the enclosure too. To check things out, about half-way through adding the bits to the PCB, I thought I should plug it in - and got the behavior listed above :frowning:

Can you post some pictures of your soldered connections?



(flipped horizontally relative to front).

I’m not quite done yet (hence several of the connections not actually begin soldered yet and several others without the leftover wire removed), and I’m still not very good with a soldering iron, hence my fear that I broke something. In my mind, the next diagnostic step is to remove all the connections to the Photon to confirm I didn’t break it, then add them back one-at-a-time to find the problematic one.

Unless of course someone has a better idea of how to approach this.

Another view of the back (this time more straight-overhead to better identify that the ABC/13 area only has the left-to-right traces crossed (intentionally):

Like I said though, I’m more than willing to admit that my soldering (or circuit-setup) skills have failed me here - just wanted to see if there was anything else I should check before taking things apart.

Sure isn’t pretty, but not as bad as I was imagining.
Any chance you pressed down on the square metal plate over the chipset? It can short out the works if it gets dinged or flexed inward.

There’s definitely an air gap between that metal plate and the stuff underneath it. I pried up a bit on the edges, but nothing seemed to give much there.

Unsoldered all the remaining connections to the board, and still not working. Guess that’s what I get for not putting a socket on the board… Guess I got too used to the abuse one can deal to the old-style Arduino Unos without destroying them.

Do you mean you’ve taken the Photon out of the PCB and it’s still dead?

I’m seeing a similar issue after trying to power up a photon for the first time using 5V on VIN. No indicator light. D7 is solid blue. Connecting to USB, I see 4.8V on VIN and 4.75V on 3.3V pin :-S. The 3.3V pin voltage makes me think its dead, Jim. Is there hope?

@tripzero, what was your 5V source?

5V is not always good 5VDC. If you had a pulsing 5V rather than filtered then your regulator might be gone.
You can replace it with some soldering skill.

To check if the device itself is still alive, you can use a relyable well filtered 3.3V source on the 3V3 pin.

1 Like

I’m using a Drok constant voltage/current power supply ( It might be spiking when first turned on, but it’s hard to tell other than it’s contributed to two photon deaths and the observations that the led matrix also connected to the power supply flashes when connecting power before the power supply is actually turned on.

3.3V on the 3v3 pin does nothing different. I’m going with b0rked.

As for mine, I’ve not been able to successfully free it from the board I’d soldered it to (can’t get enough of the 8 pins with solder on them hot at the same time to pull it off), but I’ve removed all the connections from those soldered pins, so unless the board is in some way interfering with it, I think I broke the Photon. Ordered sockets with the next one so I can add/remove the Photon easily (and avoid damaging it while building the circuit).

As a tip moving forward, I usually solder female headers to my boards so I can easily pop in and out the photon.

1 Like

May I suggest - for your tool box -
solder wick -

or a desoldering pump-


1 Like

Of the two, I’d recommend the solder sucker. I never got the hang of desoldering braid.

I should mention - I’ve tried both - I can’t get the last bits of solder off the connections to pull the chip free with either approach. I can make the connections look much cleaner with the desoldering pump, but not pull everything off, and I must be doing something wrong with the braid - I hold it along the connection like they do in the videos, and nothing happens. Even try heating the copper braid with the iron directly, and just a bit of solder transfers - not even close to fully cleaning out the connection.

Finally ended up just severing all the headers to get the bad chip out - sure enough, still dead once it’s free of the board. No worries - got the two I ordered last week over the weekend - back to tinkering.