Photon continuously disconnects for seemingly no reason

I currently have six Photons all connected to a number of machines. They time when the machine starts and stops. On four of the machines the photons work great, but on two of them I am running into the same problem. I am constantly getting this update in my console. I am running on 0.8.0-rc.8 (prerelease) firmware.

Everything is the same across each Photon but for some reason these two just want to be annoying. I’ve tried powering down and back on again but it just keeps doing the same thing. I was thinking that it may be the physical board itself, maybe I soldered something bad, but I tested each and every one of the boards before installing them and they all worked perfectly.

Any ideas would be greatly appreciated.

There are numerous possible reasons

  • physical location of the device in respect to AP
  • free DHCP IP range on the AP/router
  • potentially blocking code parts
  • EMI

With such lmited background info about the actual setup remote diagnosis is near impossible.