Photon blinking green

I tried the following steps.
Pressed the Button for about 10+ sec. Blue flashing fast.
particle serial wifi
Entered the credentials.

Directly after entering the wpa2 it flashes green. The mentioned reboot will not be performed.
After an time the photon then switch back to slow blinking blue.

Did you have an idea?
I also performed the steps above. But this does changed the behavior.

1 Like

So you don’t even get the prompt for either the WLAN cipher or the password?
That’s odd.
You have got CLI v1.14.2, right?

Could you try the oldfashioned way via a serial terminal and entering w?


Also you never had used WiFi.selectAntenna() to choose the external antenna and not got it connected now? (just checking ;-))

When I enter “particle serial wifi” I get the following lines:

particle serial wifi
? Should I scan for nearby Wi-Fi networks? Yes
? Select the Wi-Fi network with which you wish to connect your device: WIFI1
? Should I try to auto-detect the wireless security type? Yes
Detected WPA2(PSK/AES/AES) security
? Wi-Fi Password xxxxxx
Done! Your device should now restart.

But when I enter the password then it directly flashes green. (No restart as mentioned)

I didn’t have a serial terminal only usb connection. How could I managed the “old-fashioned way” ?

No I didn’t used this command.

With CLI, it tend to not use the auto-scan feature, since I know my networks :wink:

The ol’ serial way works via USB too.

  • put your device into Listening Mode (the same as with CLI)
  • open the respective COM port for your Photon with serial monitor like PuTTY
  • enter ‘w’
  • now you will be prompted for SSID, Security Scheme, WLAN cipher if the network is not currently available/visible and Pass Phrase

After that you should see your device fall out of Listening Mode and I usually press RESET after that (ol’d habbits die hard :sunglasses:)


About selectAntenna(), I had a case where a “funny” character flashed some code to his mates device that switched to the external antenna (and also a static IP), and that poor victim had a hell of a job tracking that down.

I will try that.

1 Like

It is working again. Thanks for your help.

1 Like

Did the problem just go away or what helped in the end?

Your “old-fashioned way” worked just fined. After this it worked as aspected.

1 Like

hello sir ,
have you found solution for this problem. actually yesterday i flashed my photon with this code

void setup(){}
void loop(){
WiFiAccessPoint aps[20];
int found = WiFi.scan(aps, 20);
for (int i=0; i<found; i++) {
    WiFiAccessPoint& ap = aps[i];
    Serial.print("SSID: ");
    Serial.println(ap.ssid);
    Serial.print("Security: ");
    Serial.println(ap.security);
    Serial.print("Channel: ");
    Serial.println(ap.channel);
    Serial.print("RSSI: ");
    Serial.println(ap.rssi);
}
}

untill then, i can’t flash my photon anymore. please reply me
thank you

Have you tried entering safe mode?

https://docs.particle.io/guide/getting-started/modes/photon/#safe-mode

(I deleted your identical post in another thread–double posting is not allowed.)

Thank you sir,
the problem has been resolved .

1 Like

@tmitchell… I am also having the same problem here…
What should I do?