Photon and Artoo

Hi everybody,

I have seen that the Artoo-Spark project has not been updated for nearly a year now. I tried to use with a photon and does not seem to work, hehe. Did anyone try to use this gem ? Is there a way to use Ruby and Photon somehow ?



@Abouboune, what Artoo project are you referring to?

1 Like

@Abouboune, I have used Cylon.js and Particle, you can find here, but not Artoo. While searching found this

Not sure this will help you or not.

I’m going to assume this:

Okay, I’ve stared at it for a bit, and although I don’t know ANY Ruby, I’m not sure why it wouldn’t work. It just makes calls to the Tinker firmware, which also runs on a Photon (provided you haven’t flashed your own firmware over it!) Could you confirm whether or not Tinker is running on your Photon by trying the mobile app, or checking this page to see if the Tinker functionalities are showing up?
You could try editing the URL to the currently more accurate api.particle, rather than api.spark, but that really shouldn’t make a difference.

Have a look at this as well, might just be what you’re looking for :slight_smile:

1 Like

Thanks everybody for your feedback !

I have been looking at artoo-spark gem for ruby. It is very old, I saw they did not change the uri to but even with this modification it still does not work.

CylonJS worked perfectly.

Also as mentioned above (and to increase their visibility), those two repos are promising.

I had a quick look and Particlerb is just like particle CLI but for oriented objects with ruby. Ruby_spark works fine to control devices separately, it is very easy to use. I really think they are the way to go the moment I write this message if you want to use ruby and your particle devices.