AJAX web to photon recent issue

Has something happened with AJAX in a web browser or a recent Photon update that has broken AJAX XMLHttpRequest() commands. I have been using an .ino and .html pair for several years that has worked very consistently, and worked in April 2019, but presently does not seem to work.

I think it might be a CORS issue or a photon update but really not sure.

Github here:

I will try to post a simple version of my issue. The problem seems to be when sending the form parameters. Curl commands work, sending curl commands in a node program works, just from the website seems to be an issue.

I guess this might be the reason

1 Like

Yes I think that might be related :joy::joy::joy::joy:

Thanks @ScruffR as always I really appreciate your knowledge base about Particle and your speed at replying. Your link did the trick and saved me hours of time researching other tangents (CORS, chrome updates, photon version etc etc) .

Just needed to replace




My code must be really old!

1 Like